• December 06, 2019, 10:43:08 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Bricked, am i screwed?  (Read 3312 times)

TNAJanssen

  • Level 1 Member
  • *
  • Posts: 6
Bricked, am i screwed?
« on: September 12, 2016, 07:44:12 AM »

Hi All,

I tried to flash DD-WRT (already did it a couple of times, also have had Tomato) and it rebooted into flashing amber power light.

Alright i thought, no biggy just boot emergeny mode....

But it isn't reachable, i can't ping, traceroute or get to ip 192.168.0.1 on 2 different computers!

Please give me some tips, i don't want to live without this accesspoint!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47961
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bricked, am i screwed?
« Reply #1 on: September 12, 2016, 07:49:00 AM »

Link>Welcome!

  • What Hardware version is your router? Look at sticker under the router case.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?

Did you use this? Emergency Recovery Mode

When you changed to DDWRT and loaded there FW files, which file did you use? FactoryToWRT or just the SystemUpgradeImage file?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

TNAJanssen

  • Level 1 Member
  • *
  • Posts: 6
Re: Bricked, am i screwed?
« Reply #2 on: September 12, 2016, 07:53:21 AM »

Hi FurryNutz,

Thanks for the fast reply!

I'm on HW version B1, the firmware i can't see because it won't boot up at all, not even the recovery mode.

I'm in the Netherlands, so EU based region.

I first used factory to WRT, then from WRT used the real DD-WRT firmware. It said rebooting, but all i got flashing amber power led.

Tried to go to recovery mode using your link (like i already did before), but it isn't reachable at all.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47961
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bricked, am i screwed?
« Reply #3 on: September 12, 2016, 07:56:19 AM »

I presume something has over written the nvram portion of the router where D-Links Recovery partition resides. When this happens I presume the router would be bricked if it wont boot to any state using what you tried to load. I would contact DDWRT support forum and see if there is any way to recover the unit. Not sure if D-Link will warranty while in this state.  :-X
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

TNAJanssen

  • Level 1 Member
  • *
  • Posts: 6
Re: Bricked, am i screwed?
« Reply #4 on: September 12, 2016, 08:14:38 AM »

Awh that sucks, it sucks that the firmware 2.0 doesn't support bridge mode then all this hassle wasn't necessary...

I will contact the reseller who sold me the D-Link for the warranty i think!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47961
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bricked, am i screwed?
« Reply #5 on: September 12, 2016, 08:24:10 AM »

Hope you can get a replacement.

I know my Rev A supports bridge mode, however Rev B, I don't know. Rev B was sold or supported in the USA.  ::) Rev A makes a great bridge.  ;D
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

TNAJanssen

  • Level 1 Member
  • *
  • Posts: 6
Re: Bricked, am i screwed?
« Reply #6 on: September 12, 2016, 08:29:56 AM »

I have flashed REV A firmware couple of times on it with success! Still i don't like the interface haha, i will post when i get the reply from my reseller!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47961
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bricked, am i screwed?
« Reply #7 on: September 12, 2016, 08:36:10 AM »

Let us know how it goes.  ;)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

TNAJanssen

  • Level 1 Member
  • *
  • Posts: 6
Re: Bricked, am i screwed?
« Reply #8 on: September 15, 2016, 10:29:12 AM »

Even got something better! Bought an USB to TTL cable, and fixed it with that! I needed to do an NVRAM erase and boom emergency room was up!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47961
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bricked, am i screwed?
« Reply #9 on: September 15, 2016, 10:30:54 AM »

I figured the NVram was busted. Glad you got it back.
What was the process. Could to provide some steps?
Was the cable connected to the USB port or did you have to open the router case?  ???
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

TNAJanssen

  • Level 1 Member
  • *
  • Posts: 6
Re: Bricked, am i screwed?
« Reply #10 on: September 19, 2016, 03:12:51 AM »

Yeah, i will post a guide today!

I had to open the case, then you a couple of solder holes between the LED's. You must solder a couple of male pin headers in there, connect the cable and you have serial access!

I could see there, it booted up but the network configuration was messed up. And now i'm using it to reverse engineer the original firmware...

I need/want bridge mode, i did it now through disabling DHCP, but then the internet green LED is off and i lose 1 port! Do you have any ideas?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47961
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bricked, am i screwed?
« Reply #11 on: September 19, 2016, 07:22:07 AM »

Please please post details and the process. Interested on how you open the case with out damaging it.

I know that there maybe forth coming updates for the Rev B model so maybe they might put in Bridge mode. You might contact D-Link support and request this. The 868L is matured and headed to EOL for development so you might get D-Link to add the bridge mode feature for one last update. I wish they would do one more update on the Rev A and fix the QoS issue it has. Other than this one issue the Rev A is solid.

I think if you are using bridge mode and the internet LED is not lit, then that maybe a configuration of the code since it's not actually enabled on Rev B. I think on Rev A, bridge mode it shows as amber or OFF. The Internet globe LED is for connecting wired LAN cable to the WAN port and that the indicator for that port.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting