The Graveyard - Products No Longer Supported > DNS-320

[SOLVED] - Help me to unbrick my DNS 320 A1

(1/3) > >>

Hello guys,
I have a DNS 320 rev A1 that worked like a charm for several years with an unofficial firmware (ALT-F).
Two weeks ago I decided to upgrade that firmware, but things gone wrong
So i soldered the jtag connectors and successfully  logged in with tera term.
But, how I can break the autoboot sequence and go to the u-boot command prompt?
I tried several schemas, press "space" on start.
Press space +1 on start
PRess space +1 several times on boot
PRess space +1 only once before the request "PRESS ANY KEY TO STOP AUTOBOOT".
What can I do?

Have you tried asking on the Alt-F forum!forum/alt-f ?


--- Quote from: ivan on August 12, 2016, 10:06:30 AM ---Have you tried asking on the Alt-F forum!forum/alt-f ?

--- End quote ---
Already tryied, but it seems that it's a desert group.
Actually I solved to login to the u-boot shell due to bad solders.
I want to boot the kernel from the a usb pendrive so I can flash it from the webgui.
How can I do that?

I never used u-boot

this is what I tryied:

--- Code: ---Marvell_DNS320>> usb start
(Re)start USB...
USB:   scanning bus for devices... 2 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
Marvell_DNS320>> usb storage
  Device 0: Vendor: CBM      Prod.: Flash Disk       Rev: 5.00
            Type: Removable Hard Disk
            Capacity: 1998.0 MB = 1.9 GB (4091904 x 512)
Marvell_DNS320>> fatls usb 0:1
            system volume information/
 27810631   dns-320_a1_fw_v2.00

1 file(s), 1 dir(s)

Marvell_DNS320>> fatload usb 0:1 0x1000000 dns-320_a1_fw_v2.00
reading dns-320_a1_fw_v2.00

27810631 bytes read

--- End code ---
But how can I boot the kernel off the usb drive?

Any status on this?  ???


--- Quote from: FurryNutz on August 26, 2016, 07:15:34 AM ---Any status on this?  ???

--- End quote ---
Actually I can boot into the alt-f webpage but it' has a weird behaviour, plus I can't reach the proper firmware upload page (I WANT TO RESTORE TO THE ORIGINAL FIRMWARE).
It' prompt me a "Unsupported unknown board" message.
I'm very tired, but I hate to throw away a functional NAS when it's only a matter of software.
In the alt-f group forum I had no answer.
The same on the

It's a nightmare.
The nas only boot up, show me a limited ALT-F interface but for some minutes, plus the fan it's completely ignored and it's turned off.

If someone can save my nas... please, help me.


[0] Message Index

[#] Next page

Go to full version