• September 19, 2019, 10:13:36 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations  (Read 3294 times)

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47761
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

pwigfull

  • Level 1 Member
  • *
  • Posts: 4
Re: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations
« Reply #1 on: June 17, 2016, 05:57:26 AM »

I've been having trouble upgrading the DCS-942LB1 from 2.00_4017 to 2.10.07.

I have two of these devices (both rev.B) and encounter the same problems on both.

The 2.00_4017 firmware is stable, but when I upgrade to 2.10, the cameras have trouble maintaining a wireless network connection.  Most notably, when you perform a soft reboot (i.e. select "reboot" from the web interface, or schedule a reboot), the device does not connect to the network.  A "hard" reboot (i.e. unplugging the device) usually solves this issue.  If I reset my router,  the cameras do not connect.  Both continue to show a steady green LED although they are not connected to the network.  The camera continues to record. 

This problem does not happen 100% the time, but I would estimate that it occurs 4 out of 5 soft reboots.  Again, this is happening on both of my DCS-942LB cameras, so it's unlikely to be a hardware issue.

EDIT: Some further notes.

I upgraded the firmware through the Canadian mydlink.com website (https://ca.mydlink.com/device).  The cameras were bought in Canada.

The MyDlink website urged me to upgrade to 2.10, but if I look at the support site for the DCS-942L camera (http://support.dlink.com/ProductInfo.aspx?m=DCS-942L), the latest firmware is 2.00.4017.

I have also tried downloading the "World-wide" firmware file and flashing using the web interface, but have the same problems (again, on both cameras).
https://ca.mydlink.com/device

I use a Netgear Nighthawk R7000 router, but the problem also occurs with my previous router which is a Linksys WRT310N.

Thanks for any help you can give me,
PW
« Last Edit: June 17, 2016, 10:10:49 AM by pwigfull »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47761
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations
« Reply #2 on: June 17, 2016, 09:27:53 AM »

Link>Welcome!

What wireless modes are you using? Try using single mode G or N and set WPA2 TPIK only.
What is the distance between the Camera and the main host router?

Test cameras with uPnP and uPnP Port Forwarding both enabled on ALL cameras: DCS Cloud (L) Series Camera Configuration and Mydlink.com
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

pwigfull

  • Level 1 Member
  • *
  • Posts: 4
Re: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations
« Reply #3 on: June 17, 2016, 10:10:23 AM »

Thanks for the response.

I am using WPA2-PSK [AES] for the security.  The camera is about 15 feet away, but I can place it directly beside the router and still have the same issues.  I am using dual G & N bands, and am reluctant to give this feature up for the sake of this camera.  However, the issue still is a problem using my old router which is not a dual band (LinkSys WRT310N).

I'll try playing with the UPNP settings, but should that matter? The problem is getting the camera to connect with the router and obtain an IP address.

Again, if I use the previous firmware (2.00.4017), there are no issues.




Thanks,
PW
« Last Edit: June 17, 2016, 10:17:20 AM by pwigfull »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47761
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations
« Reply #4 on: June 17, 2016, 10:13:17 AM »

Try TPIK only and see.

I would also downgrade one camera back to v2.00 and test both at the same time, If the other keeps exhibiting problems, then I would downgrade the other as well.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

pwigfull

  • Level 1 Member
  • *
  • Posts: 4
Re: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations
« Reply #5 on: June 17, 2016, 10:24:30 AM »

Unfortunately, I don't have a TKIP-only setting on the R7000.  I have:
- WPA2-PSK [AES]
- WPA-PSK [TKIP] + WPA2-PSK [AES]
- WPA/WPA2 Enterprise

I currently do have the two cameras running different firmware, and the problem still exists.

Looks like I'll have to downgrade.  Hopefully there are no security concerns with the older firmware.  I hope this may be fixed in a future release, as it's very annoying to have the "upgrade your firmware" warning appear when trying to connect.  Sooner or later I'll click the "UPgrade" button instead of "Cancel" and accidentally brick the thing.

Thanks for your help,
PW
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47761
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations
« Reply #6 on: June 18, 2016, 12:11:58 PM »

Might try WPA PSK...

Ya, try the down grade and let us know if the problem goes away...
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

pwigfull

  • Level 1 Member
  • *
  • Posts: 4
Re: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations
« Reply #7 on: June 28, 2016, 08:44:18 AM »

Yes, as I mentioned, both cameras work fine with the older firmware.  The big problem with the new firmware is that the cameras can't seem to reconnect to my network when they're "soft" rebooted (i.e. via the web interface or on a schedule).  They usually connect without issue if they are unplugged and plugged in again.  However, if they lose their connection (e.g. when the router is rebooted) they cannot re-connect without being powered off and on.  Despite not being able to connect, the LEDs remain green.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47761
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: New - DCS-942L Rev B - Firmware v2.10 Comments & Observations
« Reply #8 on: June 28, 2016, 08:49:02 AM »

I would go back and downgrade to prior working version and test. I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. This needs to be reviewed by D-Link support. Reference this forum thread if needed. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting