• October 21, 2019, 10:40:56 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: W110 Problem  (Read 3666 times)


  • Level 1 Member
  • *
  • Posts: 1
W110 Problem
« on: May 28, 2016, 09:53:27 AM »

I can not get it to connect.  Ive tried to add the devices (bought 3) and non of them will work,  It times out, and so on.

Ive tried on two networks (home and office) with the same results.

I already reset the Dlink by holding the wps button for 10 seconds, deleted the app and reinstaled it (twice) and updated the software on my iphone 6.

Any help will be appreciated!!!


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47844
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: W110 Problem
« Reply #1 on: June 06, 2016, 07:54:40 AM »

Can you connect them to the main host routers SSID name and PW instead of using WPS?

What Mfr and model# router do you have?
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting