The Graveyard - Products No Longer Supported > DIR-895L

DIR-895 Poor Wifi Performance

(1/4) > >>

Hey All,

I'm hoping someone can help me, I had a weak signal in my bedroom usng an Apple Time Capsule therefore I wanted something more powerful, I saw this and it screams power. I now get a stronger signal now in the room but extremely poor wifi performance from the DIR-895, considering its got 8 yes 8 antennas I find this hard to believe.

Old Setup:
1GB Fibre Connection with PCCW - Based in Hong Kong.
Apple Time Capsule AC  -Connected via Single Cat 6 Ethernet cable into WAN port.
Macbook pro retina 2015

Connected via ethernet cable directly to my mac pro via thunderbolt adapter 930mb down & 744mb, it's up not quite 1,000mb but close enough.

New Setup ( Same as above replacing Apple with D-Link)
1GB Fibre Connection with PCCW - Based in Hong Kong.
Single Cat 6 Ethernet cable running from fibre modem to DIR-895 plugged into the internet port.
Macbook pro retina 2015

D-Link running latest firmware 1.02 ( I think the performance was better before I upgraded but I didn't save any screenshots)

All wifi tests were performed sitting beside the Apple & Dlink -  While I understand testing using speedtest isn't a good way to measure wifi performance as all kinds of things can affect these tests It's accurate enough. I'm going to setup ipref  to perform some more tests.

Connected via ethernet cable directly to my mac pro via thunderbolt adapter 804mb down & 604mb, slower than the apple on the cabled connection.

Wifi Tests
Apple: 342 / 518

D-link ( Smart Connect Enabled) : 35 / 25 :(

I thought maybe something was going on with Smart Connect, I disable that, setup a 2.4GHZ & 5GHZ network

2.4 Performance: 141 / 135 - Better than with Smart Connect Enabled.

5GHZ Performance 43 / 30 - Worse than the 2.4 performance... !

Scan of other networks around:

At this point I'm pulling my hair out, I'm almost going to buy another WIFI dongle... Maybe theres and issues with Mac / Apple products, my Iphone and IPad have the same issues.

Any new beta firmware I can try?  Or any alternate configurations?

I'm gong to try a factory reset now to go back to scratch. I'll report back how that goes.


Factory Reset didn't improve anything.

I tried to download the firmware to version 1.00.B11, I get the message "Firmware Upgrade Failed"



* Was a Factory Reset performed before and after any firmware updates then set up from scratch?  Link> >FW Update Process

Internet Service Provider and Modem Configurations

* What ISP Modem Mfr. and model # do you have?
Be aware that wireless speeds will not achieve the same speeds seen on wired LAN cable tests. Not all wireless clients are the same and do have limitations. I would ask Apple what they are supporting.

Looking at your wireless scan capture, your channels 1 and and 36 are busy. if you are testing on these channels, then you might be getting some interferences. I would change to 11 on 2.4Gz even thought there is one other on there however looks to be at a distance. 5Ghz I would change to 161 or 165 on one of the 5Ghz radios to test with.

Be sure all other wireless devices are turned OFF and disabled, i.e. Apple WiFi routers.  Set IPv6 to Local Only and Disable WPS as well to test.

Also be aware: >WAN and LAN Connection Rates and ISP Speeds FAQ


Thanks very much for the reply.

I did a factory reset, tried again it didn't work. I then extracted the zip file and uploaded the bin file and it worked..... Guess i was being a little stupid there...

Ran the test again : almost 400 and 300 - Something is broken with the latest firmware, 1.00 works performs much better for me.

I understand that the wireless will never be as fast as wired even tho they are claiming:
"Simultaneous Tri-Band: Deliver faster Wi-Fi speeds of up to 5332Mpbs (1000Mbps + 2166Mbps + 2166Mbps)"

I'll try moving around the 5GHZ Channels to see if I can improve, It's still not as fast as the Apple... Which really p*sses me off... But I'll continue to test.


Ok i tweaked the wifi channels as suggested ( Turning off Smart Connect - doesnt seem so smart anymore)

Yay its faster than my Apple! Im happy now at least...

Thanks for the help, im still avoiding version 1.02 of the firmware tho



[0] Message Index

[#] Next page

Go to full version