• November 23, 2020, 11:38:49 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DWA-192 not able to connect on 5Ghz / Wrong password error  (Read 3948 times)

emsite

  • Level 1 Member
  • *
  • Posts: 3
DWA-192 not able to connect on 5Ghz / Wrong password error
« on: March 03, 2016, 12:54:43 PM »

I have recently acquired D-Link DWA-192 AC1900 Wireless Adapter for use with MAC OS X (El Capitan) since it supports OS X officially. I have successfully installed the latest driver updated on 29-02-2016 which makes it compatible with El Capitan and proceeded testing it using an ASUS AC-68U Router (latest firmware updated):

- it successfully connects on 2,4 Ghz (WPA-2 enabled)
- the 5Ghz network is listed, it asks me for the password and it tries to connect for about 2-3 minutes and fails with a "Wrong password, try reconnecting" error. I have triple-checked the password and also disabled all WPA encryption - made it open-system (no password). Even without password enabled, the DWA-192 software still gives me the same "Wrong password error".
- I have also tried to change the 5Ghz network settings from the router - to set it only to N, only AC, N/AC Mixed and changed the bandwidth channel from Auto (20/40/80Mhz) to each of these values, without any success.
- please note that I can succesfully connect to the 5Ghz network using any other device, so it is not a router issue, but the DWA-192 adapter.

Please help me solve this issue. And do note, before advising me to contact support to regional offices via phone I have already tried to do that, but it seems in Europe, phone support is not available.

I am looking forward to receiving your reply as soon as possible. Thank you.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49361
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWA-192 not able to connect on 5Ghz / Wrong password error
« Reply #1 on: March 08, 2016, 03:18:46 PM »

What Mfr and model is the main host router?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

emsite

  • Level 1 Member
  • *
  • Posts: 3
Re: DWA-192 not able to connect on 5Ghz / Wrong password error
« Reply #2 on: March 10, 2016, 12:47:32 PM »

Hello,

The router is ASUS RT-AC68U. I have already updated the router to latest firmware, reset to factory defaults, remove entirely the password for 5Ghz, tried various options with no avail. Even with no password set, the DWA-192 is still returning "Password wrong" error, without even needing/asking for a password. Meanwhile, all other devices are connecting successfully to 5 Ghz, only the DWA-192 does not work. It seems to be an OS X Driver issue.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49361
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWA-192 not able to connect on 5Ghz / Wrong password error
« Reply #3 on: March 10, 2016, 12:53:29 PM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

emsite

  • Level 1 Member
  • *
  • Posts: 3
Re: DWA-192 not able to connect on 5Ghz / Wrong password error
« Reply #4 on: March 21, 2016, 04:06:45 AM »

Hello,

Can you please guide me where I can find the regional phone number for Romania? Because I can't seem to find it on D-Link website.

I have already created a support ticket more than 2 weeks ago and it hasn't even been assigned yet after 2 weeks.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49361
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWA-192 not able to connect on 5Ghz / Wrong password error
« Reply #5 on: March 21, 2016, 07:16:26 AM »

I would start here and see if they can direct you to the correct place for help and information:
http://www.dlink.com/ro/ro/contact-d-link

Hello,

Can you please guide me where I can find the regional phone number for Romania? Because I can't seem to find it on D-Link website.

I have already created a support ticket more than 2 weeks ago and it hasn't even been assigned yet after 2 weeks.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!