• October 26, 2020, 12:14:34 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DNS-343 (FW 1.05) N-ACL's  (Read 1991 times)

markopas

  • Level 1 Member
  • *
  • Posts: 2
DNS-343 (FW 1.05) N-ACL's
« on: August 01, 2016, 05:35:48 PM »

Hi All,

Just wanted to say hi, new user on the board (long time lurker).

I have my DNS-343 setup and working great, but I have recently come up to a problem in regards to the user access.

Right now I currently do not have users or group setup since I am using this at home and my settings under network access for Volume_1 does not require authentication.  I like it like this as it makes things easy and simple.

Here are my current settings:
NFS Server: Disable
Type: SMB
Category: User
Folder: Volume_1
Permission: R/W
Oplocks: No
Archive: No

I recently bought a new printer an HP X576dw and wanted to setup the print to network folder option and the only way I could make this feature work because nothing else would was to create a username and password under Users / Groups and then went back to Network Access and created a share to the folder I want this user to have access to.  In my case it was Volume_1/Documents/Scanned  which now maps on my Mac as smb://<ip address>/scanned

The problem with the above is as soon as I enabled this share, I lost access to Volume_1 all together.  No matter what I do, the only way I can get full access back to this folder is to remove the share I just created above.  It's such a catch 22 that I'm stumped on why this would act the way it does especially if I leave Volume_1 with the above settings which allows all users to access it with no password required.
Logged

markopas

  • Level 1 Member
  • *
  • Posts: 2
Re: DNS-343 (FW 1.05) N-ACL's
« Reply #1 on: August 02, 2016, 05:27:51 AM »

So shortly after working on this - I figured I would post up on the resolution.

I basically ended up leaving the printer user I created shared to that specific folder (share) and created two more users and added them to a group which was tied to the main Volume_1 drive/path.  I created them to use the same username and password as my current Mac's use which allowed me to reconnect without issue.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS-343 (FW 1.05) N-ACL's
« Reply #2 on: August 02, 2016, 07:04:56 AM »

Link>Welcome!
Glad you got it working. Thanks for posting information on how you did it.

Enjoy.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!