The Graveyard - Products No Longer Supported > D-Link Multimedia and USB

Flashed wrong firmware on DWP 157 usb modem


i have D link DWP 157 A1 version of usb dongle, when i tried to upgrade the firmware in windows 10, i accidently flashed firmware of DWM 157 modem.
After that the modem was never recognized by my laptop. i tried flashing DWP 157 firmware again, but it says : no USB COM Port Detected. Please help me bring my modem back from dead.


* What Hardware version is your modem? Look at the sticker under modem.
* Link>What Firmware version is currently loaded? Found on the modems web page under status.
* What region are you located?

Model : DWP 157
H/W Ver : A1
Country : IN (INDIA)
Firmware Loaded now : D305A_14F7_V5.3.6.7_DTLW1(3.0.1EU) (DWM 157 Modem)
Firmware : D310A_1100_V5.3.0.5_DTLW2(1.0.2IN) (DWP 157) this needs to be flashed

I don't have any experience on this. I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.


[0] Message Index

Go to full version