D-Link Wireless Adapters > DWA-192

DWA-192 crashing on 5Ghz network (SOLVED)

(1/7) > >>

I'm having an issue with the DWA-192 AC1900 adapter. I followed the instructions and installed the newest driver that I grabbed on the website.
As soon as I connected to a 5Ghz network, the WiFi disappeared from my computer.
I went into Device Manager and found the device. The status was that it couldn't start. Code 10. I tried rebooting, which didn't work. Then, I tried to uninstall the driver and installing it again, but this time I connected to a 2,4Ghz network and it worked fine, but as soon as I tried to connect to the 5Ghz network again, the device turned off and I was back to square one.

I'm running Windows 10 Pro and my router is an Asus RT-AC68U

Best regards, Andreas

What region are you located?

What wireless modes are you using on the main host router?
For a quick test, disable WPA on the main host router temporarily and see if the 192 connects with out crashing. Re-enabled WPA after testing.

I'm living in Norway.
My router is running a dual band with a 802.11n 2.4Ghz band and a 802.11ac/n 5Ghz band.
I tried to deactivate the WPA security but the card crashed either way.

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. Please reference this thread. We find that phone contact has better immediate results over using email.
Let us know how it goes please.

New drivers available:


[0] Message Index

[#] Next page

Go to full version