• October 13, 2019, 01:49:24 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Sending Email Notification Problems  (Read 3042 times)

jon_ak

  • Level 1 Member
  • *
  • Posts: 11
Sending Email Notification Problems
« on: December 05, 2015, 08:13:42 PM »

My DCS-2630L camera refuses to send email notifications.  I have tried using a gmail account and went as far as opening a outlook.com account.  Gmail server was set to smtp.gmail.com on port 465 using ssl-tls, tried 587 also.  Outlook.com server was set to smtp-mail.outlook.com on port 587 using ssl-tls.   I tried using each port with StartTLS also and still no good.  This camera used to send notifications when I first installed it allbeit with a lot of trouble.  I had to do a factory reset due to mistakenly setting the allowed access list to deny when I was entering a IP address.
Logged

Hard Harry

  • Guest
Re: Sending Email Notification Problems
« Reply #1 on: December 05, 2015, 08:21:11 PM »

Do you have outbound set to use authentication? Also, what ISP are you on? Last, is a PC able to send email if a client is configured in the same way?
Logged

jon_ak

  • Level 1 Member
  • *
  • Posts: 11
Re: Sending Email Notification Problems
« Reply #2 on: December 05, 2015, 08:58:51 PM »

Do you have outbound set to use authentication?
There is no place in the camera configuration to set authentication such as would be found in an email client, only the protocol ssl-tls or StartTls.  Is there supposed to be this setting?

Also, what ISP are you on?
I'm in Hawaii on HawaiianTel

Last, is a PC able to send email if a client is configured in the same way?
I setup outlook.com in thunderbird and in the office version of outlook using port 587 with StartTLS and it worked fine.
Logged

Hard Harry

  • Guest
Re: Sending Email Notification Problems
« Reply #3 on: December 05, 2015, 11:52:38 PM »

Could you take a screenshot of the configuration for review? You can blur out anything personal.
Logged

jon_ak

  • Level 1 Member
  • *
  • Posts: 11
Re: Sending Email Notification Problems
« Reply #4 on: December 06, 2015, 07:57:02 AM »

i do not have the option to attach a file in the "attachments and other options" selection.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47833
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jon_ak

  • Level 1 Member
  • *
  • Posts: 11
Re: Sending Email Notification Problems
« Reply #6 on: December 06, 2015, 09:27:19 AM »

Thanks for all the input.  I discovered what is causing the error.  When configuring the camera, I activated the IP filter, entered the IP addresses that I use to enable remote viewing which apparently caused the snapshot notification to fail.  With the IP filter disabled, snapshot notification worked first time.  This is somewhat puzzling as i thought the IP filtering was only supposed to allow/deny specific addresses/subnets etc from accessing the camera.  I also discovered that with IP filtering enabled and using the mydlink app, the camera is listed as offline even though the IP address of the tablet is in the allow list of IP filtering.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47833
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Sending Email Notification Problems (RESOLVED)
« Reply #7 on: December 07, 2015, 06:32:22 AM »

Glad you got it figured out. Enjoy.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting