• October 19, 2020, 06:07:21 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Manually setting the time adds one hour to entered time  (Read 4555 times)

Jason303

  • Level 2 Member
  • **
  • Posts: 30
Manually setting the time adds one hour to entered time
« on: November 19, 2015, 08:40:06 AM »

I was setting the time in the DIR-890L router:

1) Set Time Zone to GMT -5 Eastern
2) I enabled Daylight Saving
3) Disabled automatic time configuration
4) Manually entered 2015 11 19 and 11 34
5) I then clicked Save

The time said it was 12:34 PM which was one hour later than when I manually entered. I went back and changed the manual time from 11 34 to 10 34 and clicked save again. This time the time said 11:34 AM which was what I entered the first time. I'm guessing that enabling Daylight Saving is adding one hour to the manually added time which is confusing.
Logged

Jason303

  • Level 2 Member
  • **
  • Posts: 30
Re: Manually setting the time adds one hour to entered time
« Reply #1 on: November 19, 2015, 08:46:10 AM »

My hardware and firmware are: DIR-890L HW:A1 FW:1.08

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Manually setting the time adds one hour to entered time
« Reply #2 on: November 19, 2015, 09:00:42 AM »

What happens if you manually enter time and disable DST?
What happens if you leave Auto Time Configuration enabled?


FYI, there is v1.09 available now: http://forums.dlink.com/index.php?topic=63787.0
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Jason303

  • Level 2 Member
  • **
  • Posts: 30
Re: Manually setting the time adds one hour to entered time
« Reply #3 on: November 19, 2015, 12:04:07 PM »

What happens if you manually enter time and disable DST?
What happens if you leave Auto Time Configuration enabled?


FYI, there is v1.09 available now: http://forums.dlink.com/index.php?topic=63787.0

1) If you turn off DST then the entered time is correct. When you have it enabled you have to set the time one hour earlier than it actually is. Example enter 2:02PM when the time is 3:02PM to get the correct time in the router.
2) If you set the Auto Time enabled then it sets the time one hour ahead of what the actual time is. Example its 3:02PM and it says its 4:02PM in the router.

I didn't want to use Beta code until it was ready for release.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Manually setting the time adds one hour to entered time
« Reply #4 on: November 19, 2015, 12:34:07 PM »

Ok, I'll have someone test this out and post. I'll check to see if this is intended behavior or not.

FYI, v1.09 is way better than v1.08.  ;D
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Jason303

  • Level 2 Member
  • **
  • Posts: 30
Re: Manually setting the time adds one hour to entered time
« Reply #5 on: November 20, 2015, 08:16:54 AM »

Ok, I'll have someone test this out and post. I'll check to see if this is intended behavior or not.

FYI, v1.09 is way better than v1.08.  ;D

I updated the firmware to the new beta version: DIR-890L HW:A1 FW:1.09

I restored to factory defaults for the router but this new firmware version doesn't appear to fix the time issue for the router.

1) Time using automatic time with daylight savings enabled:

Time Configuration:
Time Zone: GMT-05:00 Eastern Time (USA & Canada)
Time: 2015/11/20 12:00:42 PM
Enable Daylight Saving: Enabled

Automatic Time Configuration:
Update Time Using an NTP Server: Enabled
NTP Server: D-Link NTP Server

The time setting for the router is one hour forward than the actual time 11:00:42 AM (GMT-05:00 Eastern Time).

2) Time using automatic time with daylight savings disabled:

Time Configuration:
Time Zone: GMT-05:00 Eastern Time (USA & Canada)
Time: 2015/11/20 11:06:21 AM
Enable Daylight Saving: Disabled

Automatic Time Configuration:
Update Time Using an NTP Server: Enabled
NTP Server: D-Link NTP Server

The time setting for the router is correct 11:06:21 AM (GMT-05:00 Eastern Time) unfortunately we are using Daylight Saving so it is still one one hour off from the actual time.

3) Time using manual time with daylight savings enabled:

Time Configuration:
Time Zone: GMT-05:00 Eastern Time (USA & Canada)
Time: 2015/11/20 11:06:21 AM
Enable Daylight Saving: Enabled

Automatic Time Configuration:
Update Time Using an NTP Server: Diabled

Manual Time Configuration:
Date: 2015 11 20
Time: 11 10

The router reported time is 12:10 PM which is one hour ahead of the manually set time I entered. The correct 11:10 AM (GMT-05:00 Eastern Time).

4) Time using manual time with daylight savings disabled:

Time Configuration:
Time Zone: GMT-05:00 Eastern Time (USA & Canada)
Time: 2015/11/20 11:06:21 AM
Enable Daylight Saving: Disabled

Automatic Time Configuration:
Update Time Using an NTP Server: Diabled

Manual Time Configuration:
Date: 2015 11 20
Time: 11 12

The router reported time is 11:12 AM which is the correct time that I manually entered but unfortunately again this is with Daylight Saving disabled which we are currently currently using.







Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Manually setting the time adds one hour to entered time
« Reply #6 on: November 20, 2015, 08:21:56 AM »

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Do you have a prior router still handy by chance?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Jason303

  • Level 2 Member
  • **
  • Posts: 30
Re: Manually setting the time adds one hour to entered time
« Reply #7 on: November 20, 2015, 08:32:09 AM »

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Do you have a prior router still handy by chance?

1) ISP is Optimum Online cable internet
2) ISP modem is Cisco DPQ3925

Yes I had to swap out the DIR-890L with the old Netgear FVS318G.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Manually setting the time adds one hour to entered time
« Reply #8 on: November 20, 2015, 08:33:21 AM »

And with the tests you ran on the 890L, do you get the same or different results with the old router?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Do you have a prior router still handy by chance?

1) ISP is Optimum Online cable internet
2) ISP modem is Cisco DPQ3925

Yes I had to swap out the DIR-890L with the old Netgear FVS318G.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Jason303

  • Level 2 Member
  • **
  • Posts: 30
Re: Manually setting the time adds one hour to entered time
« Reply #9 on: November 20, 2015, 08:34:50 AM »

The old Netgear FVS318G time reports:

Date/Time: GMT-05:00 Eastern Time (Canada & US)
Automatic Adjust for Daylight Saving Time: Enabled
Use Default NTP Servers: Checked

Current Time: Friday Nov 20 11:32:47 GMT-0500 2015 which is correct.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Manually setting the time adds one hour to entered time
« Reply #10 on: November 20, 2015, 08:55:24 AM »

Is your ISP modem set up in bridge mode or router mode?
Your ISP modem is a gateway router:
http://www.cisco.com/web/consumer/support/modem_DPQ3925.html
  • If the ISP modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. Call the ISP and ask to see if the ISP modem can be bridged. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ. Also check the routers DHCP IP address maybe conflicting with the ISP modems IP address of 192.168.0.1. Check to see if this is the same on the ISP modem, and if modem can't be bridged, change the DIR router to 192.168.1.1 or .0.254.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Jason303

  • Level 2 Member
  • **
  • Posts: 30
Re: Manually setting the time adds one hour to entered time
« Reply #11 on: November 20, 2015, 10:21:56 AM »

To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged.

My static IP Address is 108.XX.XXX.XXX provided by my Optimum Cable ISP with Gateway, Primary DNS and Secondary DNS. So the modem is bridged.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Manually setting the time adds one hour to entered time
« Reply #12 on: November 20, 2015, 10:25:44 AM »

Ok, just checking to make sure there isn't any double NAT issues. Thank you for confirming this. It's been added to the list of bugs.


Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

BiggShooter

  • Level 3 Member
  • ***
  • Posts: 172
  • BiggShooter is BACK!
Re: Manually setting the time adds one hour to entered time
« Reply #13 on: November 20, 2015, 12:36:27 PM »

Ok, I'll have someone test this out and post. I'll check to see if this is intended behavior or not.

FYI, v1.09 is way better than v1.08.  ;D

I updated the firmware to the new beta version: DIR-890L HW:A1 FW:1.09

I restored to factory defaults for the router but this new firmware version doesn't appear to fix the time issue for the router.

1) Time using automatic time with daylight savings enabled:

Time Configuration:
Time Zone: GMT-05:00 Eastern Time (USA & Canada)
Time: 2015/11/20 12:00:42 PM
Enable Daylight Saving: Enabled

Automatic Time Configuration:
Update Time Using an NTP Server: Enabled
NTP Server: D-Link NTP Server

The time setting for the router is one hour forward than the actual time 11:00:42 AM (GMT-05:00 Eastern Time).

2) Time using automatic time with daylight savings disabled:

Time Configuration:
Time Zone: GMT-05:00 Eastern Time (USA & Canada)
Time: 2015/11/20 11:06:21 AM
Enable Daylight Saving: Disabled

Automatic Time Configuration:
Update Time Using an NTP Server: Enabled
NTP Server: D-Link NTP Server

The time setting for the router is correct 11:06:21 AM (GMT-05:00 Eastern Time) unfortunately we are using Daylight Saving so it is still one one hour off from the actual time.

3) Time using manual time with daylight savings enabled:

Time Configuration:
Time Zone: GMT-05:00 Eastern Time (USA & Canada)
Time: 2015/11/20 11:06:21 AM
Enable Daylight Saving: Enabled

Automatic Time Configuration:
Update Time Using an NTP Server: Diabled

Manual Time Configuration:
Date: 2015 11 20
Time: 11 10

The router reported time is 12:10 PM which is one hour ahead of the manually set time I entered. The correct 11:10 AM (GMT-05:00 Eastern Time).

4) Time using manual time with daylight savings disabled:

Time Configuration:
Time Zone: GMT-05:00 Eastern Time (USA & Canada)
Time: 2015/11/20 11:06:21 AM
Enable Daylight Saving: Disabled

Automatic Time Configuration:
Update Time Using an NTP Server: Diabled

Manual Time Configuration:
Date: 2015 11 20
Time: 11 12

The router reported time is 11:12 AM which is the correct time that I manually entered but unfortunately again this is with Daylight Saving disabled which we are currently currently using.

The US of A is not currently in DST (spring / summer only). If you set the correct time, you should not be enabling DST, which should give you the correct time for your time zone (current location). Once the US of A starts DST, that would be the time to "check" the DST box, which will set the time "ahead" one hour reflecting DST and give you the correct time (DST = spring / summer).

I did test out the DST settings, and it appears to be working like it is intended to work. 

Maybe I missed something (which happens from time to time - just ask Furry), but if I'm reading the post correctly, you should not currently have DST enabled. Hope this helps 😉
Logged
My Setup: Cable (200Mbps / 12 Mbps) > Modem (Netgear CM1000) > Router (D-Link DIR-XXXX) > Switch (Netgear Nighthawk S8000 Gaming & Streaming Switch) (HP Pro Curve Switch x2 - J9449-60001)

aka Vigilante

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Manually setting the time adds one hour to entered time
« Reply #14 on: November 20, 2015, 04:36:35 PM »

I can confirm that my DST button was enabled and the time was 1 hour  ahead. Turning it OFF set the time 1 hour back to the correct time.

I'm curious if DST has to be manually disabled when using automatic NTP services.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!