• March 06, 2021, 09:31:15 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Unable to connect to the admin website.  (Read 23787 times)

Michael Peterson

  • Level 1 Member
  • *
  • Posts: 1
Unable to connect to the admin website.
« on: May 28, 2015, 04:30:55 PM »

Hello guys.

I have the DSL-2640r router and recently I have been messing about with settings on the actual website for my router and it was working fine before I tried to make changes to it and now I can't seem to be able to connect to the website. I have tried plugging my ethernet cable in to my laptop and connecting that way and I still can't seem to connect, I tried to restart my router and I still can't connect. I don't know what I did to stop it working but I know that I was messing around on this website when it cut out I unticked all the boxes on it and now I can't tick them back. The website looked exactly like this http://suporte.dlink.com.br/suporte/emuladores/DSL/DSL-500BGII/Management/scsrvcntr.html . Is there any other way I can enable back the services or firstly connect to the routers website?



  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49531
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Unable to connect to the admin website.
« Reply #1 on: May 29, 2015, 12:13:56 PM »


  • What Hardware version is your modem? Look at the sticker under modem.
  • Link>What Firmware version is currently loaded? Found on the modems web page under status.
  • What region are you located?
  • Has a Factory Reset been performed?

PC 3rd Party Security Software Configurations
  • Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.

PC Web Browser Configurations
What browser are you using?
Try Opera or FF? If IE 8, 9, 10 or 11, set compatibility mode and test again. (For older generation routers.)
Disable any security browser Add-ons like No Script and Ad-Block or configure them to allow All Pages when connected to the router.
Clear all browser caches.
Be sure to log into the Admin account on the router.
Try turning off these features in Chrome:
Top right corner, little bars for options > Settings > Settings (on left) > Show advanced settings.
Uncheck these:
Use a web service to help resolve navigation errors
Use a prediction service to help complete searches and URLs typed in the address bar
Predict network actions to improve page load performance
Enable phishing and malware protection
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.