• October 22, 2019, 12:08:15 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: problem play avi files - FW problem?  (Read 1800 times)

biguard

  • Level 1 Member
  • *
  • Posts: 2
problem play avi files - FW problem?
« on: March 21, 2015, 02:21:11 PM »

my d-link cam upload recorded files to ftp server. my problem is that I can't play these files. I tried a lot of players with h.264 codecs and without success (linux and windows platforms).

I use newest firmware 1.03.01 (03/02/15) downloaded from support.dlink.com site.

bash# file *.avi
RIFF (little-endian) data, AVI, 640 x 480, 10.00 fps, video: H.264 X.264 or H.264, audio: uncompressed PCM (mono, 11025 Hz)

Is there any way to setup mjpeg video compress format to save recorded video files?

Maybe it is firmware bug (probably). Any solutions?
Logged

biguard

  • Level 1 Member
  • *
  • Posts: 2
Re: problem play avi files - FW problem?
« Reply #1 on: March 26, 2015, 12:57:54 PM »

I  found that problem doesn't exist in DCS firmware. Problem was in my old router.
Beware of transfer avi files through ftp in ascii mode (must be binary!!!!)

Mea culpa, mea maxima culpa  ;D
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47844
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: problem play avi files - FW problem?
« Reply #2 on: March 26, 2015, 01:14:50 PM »

Glad you found the problem. Thank you for posting information about it.

Enjoy.
 ;)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting