• October 17, 2019, 02:59:57 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: VOLUME_1 Degragrade  (Read 2337 times)

Angst

  • Level 1 Member
  • *
  • Posts: 1
VOLUME_1 Degragrade
« on: March 14, 2015, 09:19:20 AM »

I have a DNS-343 running version 1.05, raid 5 configuration, 4 x 2TB WD Green.  I have been successfully running this configuration for close to 2 years, however, recently, I have been observed a VOLUME_1 Degraded messages on the display.  The drive was working, didn't think much of it (ignored message) because the drive was functioning.  Currently, the drive sporadically works after it is reset.  Maintenance --> Disk Diagnostic --> Slot 1 FAIL.  Based on this information, are my next steps to purchase a new WD 2 TB Harddrive and replace it in slot one?  Any comments would be greatly appreciated.  Thank you.
Logged

Jacques Amar

  • Level 1 Member
  • *
  • Posts: 13
Re: VOLUME_1 Degragrade
« Reply #1 on: August 08, 2015, 06:23:46 PM »

Did you get this working?

My drive did reset and it is re-building, but I'm sure the drive is bad. What I don;t want to do is stop the rebuild until RAID is correct again, and then change the bad drive. However, It's taking for ever (bad disk is slow)

I want to know if I can shut down the device and replace the bad drive and will it re-build again, or do I have to wait for this rebuild to finish
Logged

softwizard

  • Level 1 Member
  • *
  • Posts: 6
Re: VOLUME_1 Degragrade
« Reply #2 on: August 13, 2015, 12:31:19 PM »

My DNS-343 has 4x1TB drives and won't ever sync.  It takes a long time to sync after reboot (only 500GB on the RAID5 drive) and then ends up Degraded.
Logged

ivan

  • Level 8 Member
  • ***
  • Posts: 1453
Re: VOLUME_1 Degragrade
« Reply #3 on: September 22, 2015, 04:41:40 PM »

To try and answer all.

Abgst.  If you are sure it is the defective drive then all you should need to do is replace it and assuming you have auto rebuild on then your array should rebuild.

Jacques.  Do you know which drive is faulty?  Again if you are sure of the drive then just replace it and hope the rebuild has not destroyed your data although you should be able to recover using your backup.  You may have more than one disk that is faulty because of the slowness of the rebuild so it would be a good idea the check each disk with the manufacturers disk tools (use a USB/SATA caddy or adapter to mount each drive for testing and make sure all good drives go back in the slot they came from).

softwizard.  It sounds as if you may have a faulty drive, check with manufacturers disk tools, or you might have bad sections in the parity stripe which will require reformatting and restoring from your backup.

All of the above hinges on having a good backup as well as being careful to note any error messages and responding to them as soon as possible.  While RAID 5 will tolerate one drive failure it is not to be used as a backup system on its own.  A RAID array only covers disk failure and usually only one disk at a time.
Logged