• September 17, 2019, 12:12:07 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: (!) Solution found for DWA-643 shutdown / sleep problem  (Read 3365 times)

asker78

  • Level 1 Member
  • *
  • Posts: 2
(!) Solution found for DWA-643 shutdown / sleep problem
« on: January 25, 2015, 02:12:24 PM »

I use DWA-643 with my ASUS F3Ja laptop and I stuck with a known problem of DWA-643, which prevents laptop from shutting down correctly.
Recently I tried to search a bit about ExpressCard known issues and found out, that many Apple users admitted they faced a similar problem (Apple laptop + some ExpressCard modules, such as Wi-Fi modules, cardreaders, etc = laptop restarts instead of shutting down). Finally I found a useful comment of Apple's tech specialist: https://developer.apple.com/library/mac/qa/qa1517/_index.html . I'm totally noob in electronics, but that comment explains clearly, that some modules' manufacturers do wrong implementations of ExpressCard standard in their products, hence it's likely, D-Link has implemented wrong connection scheme in DWA-643, so that most of us stuck with the previously described problem. Next, I found a scheme for ExpressCard slot: http://www.allpinouts.org/index.php/PCI_Express_Card_and_PCI_Express_Mini_Card . And I wondered if that "wake#" (number 11) pin was the cause of the problem. The scheme says, this pin is "optional", not mandatory. And I tried to cover it with a narrow piece of scotch tape. If you observe the connection plug in a way, that the row of pins is at the bottom, the numeration of pins starts form the right end. 11th pin is short and it's located between two long pins. Also, if you compare first left pins with the scheme, you will ensure, that long ones correspond to GND. Hence, the direction of pins' count is right.
After sealing the 11-th pin I inserted DWA-643 and tried to power up my laptop. Everything is fine now, and my laptop is able to shutdown normally. I use driver ver. 6.0.3.67 (2007) from http://support.dlink.com/ProductInfo.aspx?m=DWA-643 , and connection bandwith is 300 Mbit / s.

DISCLAIMER OF WARRANTIES AND LIMITATION OF LIABILITY:
The "solution" for the problem is supplied “as is” and all use is at your own risk. I'm not tech specialist, I just described the solution which worked for me fine.
« Last Edit: January 25, 2015, 02:22:57 PM by asker78 »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47755
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: (!) Solution found for DWA-643 shutdown / sleep problem
« Reply #1 on: January 25, 2015, 02:19:47 PM »

Thank you for the feed back and information.

I presume that some of this information is accurate and maybe a work around needed for newer generation client HW and OSs since this model DWA is older now and it been years since it was developed on which was on older OS systems at the time thus pin and driver specs where up to date for the time:
"This product has been discontinued.
Free support for this product has ended on 01/01/2010"


Hope your work around information will help any future users. Also it would be recommended to get into a newer adapter i.e. USB since PCMCIA interfaces are not being used or marketed much any more.

Glad it's working now.

Enjoy.  ;)

Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting