• August 19, 2019, 06:37:18 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Bug report - deletion of website filters does not work first time  (Read 1694 times)

theduser

  • Level 1 Member
  • *
  • Posts: 12

Firmware: 1.02b13, Region: Canada, Browser: firefox (currrently 36.01)

1. Features > Website Filter
2. Add at least two entries - the ones I used were intellitxt.com and images.taboola.com
3. Click save

Once the router has rebooted:
1. Features > Website Filter
2. Delete BOTH entries by clicking on the trashcan icon against each
3. The list should now be empty.
4. Click save

Once the router has rebooted:
1. Features > Website Filter
2. List of sites still contains one entry
3. Delete the remaining entry
4. Click save

The list will now be empty.

Has anyone else had this happen?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47689
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bug report - deletion of website filters does not work first time
« Reply #1 on: March 09, 2015, 07:43:03 AM »

Happen with IE11 as well?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

theduser

  • Level 1 Member
  • *
  • Posts: 12
Re: Bug report - deletion of website filters does not work first time
« Reply #2 on: March 09, 2015, 08:52:42 AM »

Yes, the same behaviour is observed under IE11.  I did some further experimentation, and have narrowed down the issue.  If there are multiple entries in the site list - e.g.

site1
site2

Scenario A
Clicking delete (trash can icon) for site1 will reduce the list to:

site2

Now delete site2 and reboot the router.  Site 2 will still be present. This is a bug.

Scenario B
Clicking delete (trash can icon) for site2 will reduce the list to:

site1

Now delete site1 and reboot the router.  The list will be empty.  This is as expected.

Workaround

Delete sites from the bottom up - i.e. site2, then site1.

Note: the test was done from a wired computer, with no other devices connected to the router.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47689
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bug report - deletion of website filters does not work first time
« Reply #3 on: March 09, 2015, 09:04:08 AM »

Thank for for your results and testing. I'll forward this on to D-Link for review.

Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting