• January 28, 2020, 05:09:41 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Invalid login/password  (Read 1933 times)

Rooster

  • Level 1 Member
  • *
  • Posts: 3
Invalid login/password
« on: December 19, 2014, 09:38:20 AM »

I went through hours of this BS last night before I discovered the problem. When you've entered in all your mail setting correctly and your test emails get returned or don't go through due to an invalid login/password error, the cause is usually your ISP blocking the camera from logging into your email account to send the email. I had tried 3 different email accounts and nothing was working. DLink suggested I set up a gmail account to test it with so I did that and even that failed. However, I did get the following email from google:

Quote
Sign-in attempt details
Date & Time: Friday, 19 December 2014 04:30:49 o'clock UTC
Location: *******, **, Canada

If this wasn't you
Please review your Account Activity page at https://security.google.com/settings/security/activity to see if anything looks suspicious. Whoever tried to sign in to your account knows your password; we recommend that you change it right away.

If this was you
You can switch to an app made by Google such as Gmail to access your account (recommended) or change your settings at https://www.google.com/settings/security/lesssecureapps so that your account is no longer protected by modern security standards.

To learn more, see https://support.google.com/accounts/answer/6010255.

Once I turned off the security features for my gmail account the camera was able to use my email account to send the photos. The issue is with the camera being seen as some sort of security threat by most ISPs and they'll block any attempt to access your account by it. Only google was kind enough to warn me about the attempt. Contacting your ISP to see if they can allow the device access to your account (recommended) or remove the security from your account (not recommended) could fix the issue. Most ISPs will just block the camera's attempts to access your email account in the background and you'll never even know they did it.

Of course the best fix for the issue would be if DLink actually knew how to write some decent code and stuck to industry standard security procedures. It would appear this issue affects multiple devices. For me it occurred with the DCS-930L, but I've seen this topic pop up across many different forums. Hopefully this post will save somebody else the many hours of frustration I went through.
Logged