The Graveyard - Products No Longer Supported > D-Link Multimedia and USB


(1/2) > >>


I own a D-Link DUB H-7 7-Port USB 2.0 hub ( which is seemingly now having issues of some sorts.
I am running Windows 7 64-bit, and have also used the same hub when I was still on XP SP3. It has worked fine all along, which is always connected to the back ports on the machine.

I started suspecting that it has a problem when one of the external drives connected to it, would not initialise in Windows 7. And if it does, it would connect, then disconnect, and then do this repeatedly. I would have to plug that external into another USB port via USB extension cable to the back of the computer. So I disconnected all the USB drives from the hub, and also the main USB cable running from the back of my machine, and just left the AC adapter connected to it. The power light was not on. But when the USB cable gets plugged in, all the lights on the front of the hub light up brightly.

Underneath it says Hardware Rev. A5.

So I move the hub to the kitchen where I tried a power outlet there, and the hub ended showing a very dimly lit power button, when connected. But it went dim again after I removed it from the power socket and reconnected it.

Is this something I can fix, as I do not really feel like buying another USB hub, because anything requiring less power works fine. It's the peripherals that need a bit more power that seem to not load up.

What can I do about this?

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.

I'll call them tomorrow when they are open for business and will give feedback.


Any status on this?  ???

Got a bit held up with work and other things. Have not managed to call in to my regional D-Link support office.

However, I did a bit more troubleshooting a short while ago, as the dimly lit power light (on some occasions) vs. all the lights on the front panel of the USB hub being properly lit up when I plug the USB cable alone into the hub, was bothering me. And I started suspecting that the AC adapter that came with the USB hub was faulty / dead.

So I scratched through my "toolbox" where I know I had a universal AC adapter that I had purchased for use on my recording studio sound card. I checked that all the required input and output power figures are compatible on the original and universal AC adapters, then I connected the universal AC adapter to the hub.  And viola!  ;D  ;D

Power light was as bright as when the USB cable alone is plugged into it, as it should be when the AC adapter is connected.

So I do believe that I have resolved this issue, which was caused by a defective AC adapter (hopefully). I will still test everything by booting up all the devices that are connected to all 7 USB ports, and they should work all at once if the AC adapter is supplying enough power.


[0] Message Index

[#] Next page

Go to full version