• February 18, 2020, 04:04:12 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: dir-826l ipv6 firewall not working consistently  (Read 2291 times)

dthims

  • Level 1 Member
  • *
  • Posts: 2
dir-826l ipv6 firewall not working consistently
« on: March 29, 2014, 12:14:58 PM »

opened wan (::) to lan (2002:44c0:XXXX:XXXX::X), then ran port test. sometimes it passes, sometimes it doesn't. very inconsistent.  definitely works internally, but not externally. fw is 1.04na. 

have no trouble with ipv4. that works perfectly. any suggestions would be helpful
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48326
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: dir-826l ipv6 firewall not working consistently
« Reply #1 on: March 29, 2014, 12:17:15 PM »

Link>Welcome!

  • What Hardware version is your router? Look at sticker under router.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?
  • Are you wired or wireless connected to the router?
  • Has a Factory Reset been performed?
  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?
FW Update Process
  • Was the router working before any firmware updates?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?
  • Is ISP Modem/Service using Dynamic or Static WAN IP addressing?
  • What ISP Modem service link speeds UP and Down do you have?
  • Check cable between Modem and Router, swap out to be sure. Link> Cat6 is recommended.
  • Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
  • For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

PacketTracer

  • Level 4 Member
  • ****
  • Posts: 434
Re: dir-826l ipv6 firewall not working consistently
« Reply #2 on: March 29, 2014, 12:40:35 PM »

Hi,

sounds quite strange: A firewall sometimes passing and sometimes not.

I'd guess that IPv6 packets matching your firewall rule will always pass and in those cases you think that your firewall blocks them, packets got dropped somewhere else before reaching your router.

So why? Well, you use 6to4 known to have issues, see RFC6343.

Perhaps you could try another IPv6 access technique, e.g. 6rd (if supported by your ISP) or HE tunnel, and then test if the problem persists ...

PT
Logged

dthims

  • Level 1 Member
  • *
  • Posts: 2
Re: dir-826l ipv6 firewall not working consistently
« Reply #3 on: March 29, 2014, 03:07:58 PM »

hey, thnx for the quick replies. created that tunnel as you suggested and it's doing the same thing.  ipv6 does not work with this unit.  on the scan test, on the 4th try it said open. then about 30 seconds later, it was back closed. this time the address was 2001:X:X:X, not 2002:X:X:X
Logged

PacketTracer

  • Level 4 Member
  • ****
  • Posts: 434
Re: dir-826l ipv6 firewall not working consistently
« Reply #4 on: March 29, 2014, 06:15:00 PM »

... I hope it wasn't 2001:0::/32, because in this case you would have used Teredo where a client behind your router terminates an IPv6 over UDP/IPv4 tunnel and your router has absolutely nothing to do with IPv6? And Teredo is even worse than 6to4, being the last choice if nothing better is available.
Logged