• November 26, 2020, 04:23:36 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: 942L unable to be accessed by IP / password incorrect  (Read 2953 times)


  • Level 1 Member
  • *
  • Posts: 1
942L unable to be accessed by IP / password incorrect
« on: February 09, 2014, 10:30:43 PM »

I have set up 4 942Ls with little or no issues. All of them are working & online at this time.

The 5th 942L has been a real pain......

When setting up the camera, the password must have gotten entered wrong or corrupted.

When I follow the mydlink setup wizard, the wizard will not show the camera If I go to https://www.mydlink.com/device#, it shows the 5th camera, but it is not connected & you cannot access it.

I moved the camera to 3 different routers. Same results.

The current setup (3rd try) is the suspect 942L & the laptop only, both connected on wired connections to a Linksys Wireless-G Broadband Router, which is an older router no longer used, as I keep as a spare.

The laptop & 942L are both pulling DHCP addresses from the Linksys router. I have defaulted all the settings in the router.

When looking at the DHCP clients in the router list, the laptop & the 942L show up. When I attempt to connect with the 942L using the web browser, the connection times out & never connects. 

I have tried to ping the 942L from the laptop with no success.

I have turned off the firewall, in case things were blocked, etc. No success.

I have run the setup from https://www.mydlink.com/device#. It shows the 942L, not connected of course, but it shows up in the list, as I was able to register it on the 1st setup, when the password stopped working.

I have tried to unregister the 942L, & I keep getting a password error. I used the same password on all 942Ls before with no issues.

I have tried to do the hard reset with the paper clip, but the 942L never actually reset, even after holding the clip down over a minute, etc. I tested this on the other 942L & it worked without any issues.

Last I tried to access the 942L via telnet ( info from another post) to attempt to gain access to change the password. Telnet cannot connect to the 942L.

Any ideas, anyone.....???


  • BETA Tester
  • Level 15 Member
  • *
  • Posts: 12190
  • D-Link Global Forum Moderator
    • FoundFootageCritic
Re: 942L unable to be accessed by IP / password incorrect
« Reply #1 on: February 11, 2014, 05:01:39 AM »

The reset procedure (i.e. Pressing and holding the recessed reset button for > 9 seconds while the DCS-942L is powered-up) should bring the DCS-942L to the factory default settings, making the camera accessible with the default username/password credentials. If the reset procedure is not working for you, it's possible the camera is defective.

Another potential root cause is if you updated the firmware and the network connection or power was lost during the FW upgrade, which could very easily render the camera unusable. Presuming that you didn't touch the out-of-the-box firmware, it sounds like the camera is defective.

Since it sounds like you just purchased this camera, I recommend contacting the vendor your originally purchased the product and see if you can get a replacement (which I presume will be at no cost to you). The second option is going through the D-Link RMA process, which is also no cost, but you will have to pay shipping for sending the original camera back to D-Link. D-Link USA Technical Support: 1-888-851-6464
Find answers here: D-Link ShareCenter FAQ I D-Link Network Camera FAQ
There's no such thing as too many backups FFC