• October 27, 2020, 11:44:39 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DSL 2750-U DNS Server Not Responding  (Read 4266 times)


  • Level 1 Member
  • *
  • Posts: 1
DSL 2750-U DNS Server Not Responding
« on: December 18, 2013, 07:21:38 PM »

Modem: DSL-2750U Wireless N ADSL2+ 4-Port Wi-Fi Router (with USD port)

What Hardware version is your router? Look at sticker under router.

What Firmware version is currently loaded? Found on the routers web page under status.
Firmware Version: SE_1.01

What region are you located?
Malaysia (in South East Asia, SEA)

Are you wired or wireless connected to the router?

Wireless. Devices inclusive of mobile and laptop

Has a Factory Reset been performed?

Problem Description:
Unable to connect to Internet using wireless connection. Error message after initiating " Troubleshoot Problems" is "DNS server is not responding"
Login into modem web page. Tried to change the DNS server to Google Public DNS server settings ( & Still not working. The problem is not with my laptop DNS settings as my mobile also cannot connect to the internet using wireless connection.

What can i do ?

« Last Edit: December 19, 2013, 07:27:36 AM by kcfam »


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49294
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL 2750-U DNS Server Not Responding
« Reply #1 on: December 23, 2013, 12:39:20 PM »

Lets do a factory reset and set up the modem from scratch and use ISP DNS and see if anything clears up.

Also reboot the PC or devices after the modem has been re-setup....
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!