• September 23, 2020, 03:52:42 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: config DFL-210 for Terminal Services  (Read 8984 times)

lira3122

  • Level 1 Member
  • *
  • Posts: 11
config DFL-210 for Terminal Services
« on: May 26, 2009, 07:19:45 AM »

So I am trying to configure a Server that has Terminal Services on it.  I have used the FAQ guide located here.  http://support.dlink.com/FAQ/view.asp?prod_id=2404&question=dfl-210

Now I didn't do the check box in Step 9 because we currently have another server that is allowing RDP in.  Now that one is configured correctly for RDP. (was set up before me)  But when I try to RDP to the TS I get cannot locate server. Looking at the log I see this:

2009-05-26
09:14:48 Warning RULE
6000051 Default_Rule UDP wan
 XX.XXX.194.56
XX.XXX.80.226 37437
39274 ruleset_drop_packet
drop
ipdatalen=39 udptotlen=39 

Now the XX.XXX.80.226 is the server that is set up already but the TS server is XX.XXX.80.227.

I have put the SAT line in there as well as the ARP.  But I can't find why it isn't directing it to the 226 instead of the 227.

I have been at this for half a week.  Any help would be greatly appreciated.

Thanks,
Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: config DFL-210 for Terminal Services
« Reply #1 on: May 26, 2009, 08:55:14 AM »

Paste an image of the rule, specificly the SAT tab.
Logged

lira3122

  • Level 1 Member
  • *
  • Posts: 11
Re: config DFL-210 for Terminal Services
« Reply #2 on: May 26, 2009, 09:35:42 AM »

Here are the screenshots... First shows all rules, then general tab for the Terminal server,  Then the Sat tab for the Terminal Server.






Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: config DFL-210 for Terminal Services
« Reply #3 on: May 26, 2009, 09:51:43 AM »

You need a SAT and a NAT
Not allow.
Logged

lira3122

  • Level 1 Member
  • *
  • Posts: 11
Re: config DFL-210 for Terminal Services
« Reply #4 on: May 26, 2009, 10:21:39 AM »

well I do have some NAT.  Not sure if any of these is what your talking about?



Or what would I need?
Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: config DFL-210 for Terminal Services
« Reply #5 on: May 26, 2009, 10:23:42 AM »

Just like the SAT rule but a NAT version and the SAT rule should come before it on the list of rules.
Logged

lira3122

  • Level 1 Member
  • *
  • Posts: 11
Re: config DFL-210 for Terminal Services
« Reply #6 on: May 26, 2009, 10:39:24 AM »

Ok I put this in (don't know if it is right)  but it is still not working.



Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: config DFL-210 for Terminal Services
« Reply #7 on: May 26, 2009, 11:18:46 AM »

you don't need the NAT tab.
Logged

lira3122

  • Level 1 Member
  • *
  • Posts: 11
Re: config DFL-210 for Terminal Services
« Reply #8 on: May 26, 2009, 11:30:44 AM »

Ok I took off the NAT tab and put it back on "Use Interface Address".  Save and Activate.  And still no joy.

Still cannot connect to the computer. 
Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: config DFL-210 for Terminal Services
« Reply #9 on: May 26, 2009, 11:54:03 AM »

You might want to contact our business class support, they would be better able to assist you over the phone.
Logged

lira3122

  • Level 1 Member
  • *
  • Posts: 11
Re: config DFL-210 for Terminal Services
« Reply #10 on: May 26, 2009, 03:43:11 PM »

so trying to ping this address I get this in the log..(I enabled ICMP for this test)


2009-05-26
17:41:14 Notice RULE
6000031 DirectedBroadcasts 
 
 
 directed_broadcasts
drop

Is there a rule to drop all these packets?  I can ping my other server but not the new one.
Logged

lira3122

  • Level 1 Member
  • *
  • Posts: 11
Re: config DFL-210 for Terminal Services
« Reply #11 on: May 27, 2009, 02:31:18 PM »

Ok so I found out the guy before me had the wrong submask for out public IP addresses.  Now I fixed that and am trying to ping that ip and I now I see it in the log but am getting this

2009-05-27
16:26:56 Info CONN
600001 ICMP_in ICMP wan
wan XX.XX.171.90
XX.XX.80.227
 conn_open
 
conn=open connsrcid=12759 conndestid=12759 


I  noticed when I ping my other server it looks the same but instead of the destination being wan it is Core. so it looks like this

2009-05-27
16:26:56 Info CONN
600001 ICMP_in ICMP wan
core XX.XX.171.90
XX.XX.80.226
 conn_open
 
conn=open connsrcid=12759 conndestid=12759 

Logged

lira3122

  • Level 1 Member
  • *
  • Posts: 11
Re: config DFL-210 for Terminal Services
« Reply #12 on: May 27, 2009, 02:45:30 PM »

Ok got it working...Just deleted everything I had done and went through all the steps again.  And this time it worked...I think the submask of public messed me up the first time.
Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: config DFL-210 for Terminal Services
« Reply #13 on: May 28, 2009, 09:41:48 AM »

Glad to hear that.
Logged