• December 10, 2019, 08:08:06 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Need Help Configuring Access Filter  (Read 4248 times)

adstone1237

  • Level 1 Member
  • *
  • Posts: 5
Need Help Configuring Access Filter
« on: November 15, 2013, 06:09:10 PM »

I'm trying to configure access filters for myself and my computer to help me study because I have very weak willpower when it comes to studying. What I want to do is restrict access to only these sites:

Www.coursesmart.com
www.netacad.com

I also want to be able to access Google, specifically Google Drive, Google Calendar, and Google Keep as these sites hold my schedule, notes, and other important info. I was able to successfully set it up the way I wanted to, with a set schedule time for Saturday and Sunday between 10 AM and 4 PM. I make sure to apply these settings only to my computer, but as soon as I save the settings and my router rebooted,  it started blocking access even though it was not within the scheduled time. It wasn't until I unchecked the newly created rule and rebooted the router that I was able to access everything again.
It should be noted that in the website filter area, I put in those above addresses exactly as you see them.

So basically these are my questions:
Why is it blocking access to websites outside of the scheduled filter time?
Do I need to put the exact web address in the website filter or is it just keywords? If it is the exact address that is needed,  how can I make sure that I can access all other parts of the website?

a speedy response would be greatly appreciated, I would like to have this functioning the way I want by tomorrow.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47971
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Need Help Configuring Access Filter
« Reply #1 on: November 15, 2013, 06:35:08 PM »

To set up scheduling:
1. Reserve device IP addresses ON the router under Setup/Networking.
2. Set up a schedule under Tools/Schedule on the routers web page. Customize your dates and times here.
3. Use Access Control under Advanced to apply the customized schedule to a policy and to the PC(s) desired to be controlled.  
4. Ensure Time is set correctly on the router. Tools/Time.
5. Input web addresses into Web Filter that you wish to Allow or Deny.
6. Use the name of the schedule name that you have there. It should be listed.
7. Use Access control to set up a policy for either IP address or Mac Address of the device you want apply the policy too. Use IP address for the device your wanting to Deny access for and select Ok.
8. Select Block Some Access and Apply Web Filter.
9. Up to you if you want to capture logging information if this option is seen.
10. Select Save and reboot the router.

Your device should not have access to the Web Filter addresses that you have Denied for the scheduled time frames.
The following message will be seen in the browser during the time frames for the block sites:
"FORBIDDEN WEB ACCESS
Access to this Web site is not allowed from this computer.

This page is not included in the router's Allowed Web Site List."

« Last Edit: November 15, 2013, 06:41:29 PM by FurryNutz »
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

adstone1237

  • Level 1 Member
  • *
  • Posts: 5
Re: Need Help Configuring Access Filter
« Reply #2 on: November 15, 2013, 10:19:16 PM »

To set up scheduling:
1. Reserve device IP addresses ON the router under Setup/Networking.
2. Set up a schedule under Tools/Schedule on the routers web page. Customize your dates and times here.
3. Use Access Control under Advanced to apply the customized schedule to a policy and to the PC(s) desired to be controlled. 
4. Ensure Time is set correctly on the router. Tools/Time.
5. Input web addresses into Web Filter that you wish to Allow or Deny.
6. Use the name of the schedule name that you have there. It should be listed.
7. Use Access control to set up a policy for either IP address or Mac Address of the device you want apply the policy too. Use IP address for the device your wanting to Deny access for and select Ok.
8. Select Block Some Access and Apply Web Filter.
9. Up to you if you want to capture logging information if this option is seen.
10. Select Save and reboot the router.

Your device should not have access to the Web Filter addresses that you have Denied for the scheduled time frames.
The following message will be seen in the browser during the time frames for the block sites:
"FORBIDDEN WEB ACCESS
Access to this Web site is not allowed from this computer.

This page is not included in the router's Allowed Web Site List."



apart from step 1, I pretty much did these exact steps in setting up my access filter rule before your post. But with that said, I went back and performed step 1 for good measure.

So after configuring the rule, checking the box to enable it and then saving and rebooting the router, when I try to access pretty much any webpage, it says no data received in Google Chrome. It does not give me that message "forbidden web access" like you had posted. However, when I uncheck it and do another save reboot, everything works perfectly fine...... Kind of. Initially after successful reboot I lost Internet connection and there was that little caution sign next to the reception bar on my taskbar. It wasn't until I restarted the router again that I regained Internet connection. That might sound insignificant, but I just find it a little odd that it would do that.

I'm not sure how much it matters, but my computer is a laptop running Windows 7 64-bit Home Premium accessing the router through wireless.

It confounds me that I cannot access any website when I enable the rule despite being well outside of the time frame. I got to say however that I have not tried to access the specific sites that I put in the web filter that are supposed to be the only sites I can access during the rule's activation.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47971
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Need Help Configuring Access Filter
« Reply #3 on: November 16, 2013, 09:49:11 AM »

Be sure that your blocking some access in step 8, not all.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

adstone1237

  • Level 1 Member
  • *
  • Posts: 5
Re: Need Help Configuring Access Filter
« Reply #4 on: November 16, 2013, 11:05:30 AM »

Be sure that your blocking some access in step 8, not all.
I am positive that it is doing that, in the access control section where it lists my rules, under filtering it says Block Some Access. However like I said, after enabling and save rebooting, all sites do not load and chrome just tells me that no data has been received. in the status bar where it tells me what the browser is doing while the page is loading, all it says is that it is waiting for the specific page to send a response.
« Last Edit: November 16, 2013, 01:31:52 PM by adstone1237 »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47971
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Need Help Configuring Access Filter
« Reply #5 on: November 16, 2013, 02:19:41 PM »

SO I set up my Rev B 655 today and ran thru the process of setting up scheduling, web filters for your web sites and applying the access control, rebooted and I still have all access to other web sites however i don't have any access to your 2 web sites you posted.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

adstone1237

  • Level 1 Member
  • *
  • Posts: 5
Re: Need Help Configuring Access Filter
« Reply #6 on: November 16, 2013, 02:49:55 PM »

SO I set up my Rev B 655 today and ran thru the process of setting up scheduling, web filters for your web sites and applying the access control, rebooted and I still have all access to other web sites however i don't have any access to your 2 web sites you posted.
How strange, despite not having an account at either site, you should be able to at least see the home page. Did you try to connect to either site before activating the rule?

I will try deleting the rule, re-creating it, and then activating it to see if anything changes after it comes into effect. If that does not work and you cannot figure out a solution to get it working, I might just contact D-Link technical support directly to see if I can have this issue resolved.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47971
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Need Help Configuring Access Filter
« Reply #7 on: November 16, 2013, 03:10:11 PM »

I didn't however I set the schedule for 3-4pm and now it's pass the time frame at 4pm and I can see and gain access too www.netacad.com
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

adstone1237

  • Level 1 Member
  • *
  • Posts: 5
Re: Need Help Configuring Access Filter
« Reply #8 on: November 17, 2013, 01:04:11 PM »

I didn't however I set the schedule for 3-4pm and now it's pass the time frame at 4pm and I can see and gain access too www.netacad.com
Ok. I need to try this at a different time as I can't do it right now
Logged