• November 21, 2018, 10:29:49 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Has anyone got DIR-850L working successfully with OpenDNS?  (Read 11173 times)

User850L

  • Level 1 Member
  • *
  • Posts: 2
Has anyone got DIR-850L working successfully with OpenDNS?
« on: October 29, 2013, 03:31:28 AM »

I had an older dlink router that used to work correctly with OpenDNS, and replaced it with this new DIR-850L model. I configured the DNS addresses to point to OpenDNS servers, but the WEB filtering feature is not working anymore.

I contacted their support team and they told me that it looked like my router was not using their DNS servers, although I am sure the addresses are configured correcty.

If anyone has successfully configured the DIR-850L to work with OpenDNS, please tell me the configuration settings you are using.

BTW, I am using FW v1.09.

Thanks a lot!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46164
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Has anyone got DIR-850L working successfully with OpenDNS?
« Reply #1 on: October 29, 2013, 07:04:41 AM »

Link>Welcome!

  • What region are you located?
  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?


Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?
  • What ISP Modem service link speeds UP and Down do you have?
  • If this modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ.
  • Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
  • For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.

Router and Wired Configurations
Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router.
  • Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
  • Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual.
  • Turn OFF DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench or try manually inputting the custom DNSs into Setup/Internet/Manual
  • Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
  • Ensure devices are set to auto obtain an IP address.
  • If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6.
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules. Enable IPv6 Multi-cast Streaming for routers that have a Media Server option. Disable IPv6 Multi-cast Streaming if IPv6 or Media Server is not being used.
  • Turn off WISH, and WPS under Advanced.
  • WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
  • Set current Time Zone, Date and Time. Use an NTP Server feature. Tools/Time.

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

User850L

  • Level 1 Member
  • *
  • Posts: 2
Re: Has anyone got DIR-850L working successfully with OpenDNS?
« Reply #2 on: October 29, 2013, 03:26:07 PM »

Hi FurryNutz,

From your suggestions list, this is the configuration setting that makes Dlink's DIR-850L work with OpenDNS:

Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.

I tried them one by one in sequence, but the only setting that really worked was disabling the SPI option under:

Advanced / Firewall Settings / SPI uses = unchecked

Thanks a lot!

Best Regards,
eds01
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46164
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Has anyone got DIR-850L working successfully with OpenDNS? (RESOLVED)
« Reply #3 on: October 29, 2013, 04:27:56 PM »

Glad you got it working. Enjoy.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!