• November 18, 2018, 05:54:14 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: D-Link DIR-655, Web filtering problem with Firmware 1.31 (HOW TO)  (Read 18908 times)

aln688

  • Level 1 Member
  • *
  • Posts: 18

I have a D-Link DIR-655 router, hardware A3 and firmware 1.31. I used to have firmware 1.20 and while port forwarding never worked, web filtering did work. Recently I upgraded to 1.31 firmware and now port forwarding works, but web filtering does not.

My access control settings are basically this:

Schedule: Always
Machine: Other Machines
Method: Block Some Access
Apply Web Filter: Yes
Apply Advanced Port Filters: Yes
Add Port Filter Rules: None
Web Access Logging: Enabled

Has anyone else with this hardware and firmware combination got web filtering to work? If so, where am I going wrong? From the settings I've setup I see no reason why it wouldn't work, other than the firmware having a problem.

Thank you.
« Last Edit: July 18, 2013, 10:23:37 AM by FurryNutz »
Logged

lizzi555

  • Level 5 Member
  • *****
  • Posts: 605
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #1 on: May 16, 2009, 11:58:14 AM »

Quote
Apply Advanced Port Filters: Yes
Add Port Filter Rules: None

Why did you apply Advanced Port Filters if not using any rule ?
Set to no if the Web Filter is all you want.

If you need additional Port Filters, create a second rule which applies only Port filter Rules.

I noticed it your using both in one rule it won't work. At least for me.  ;)
Logged

aln688

  • Level 1 Member
  • *
  • Posts: 18
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #2 on: May 16, 2009, 03:00:50 PM »

Why did you apply Advanced Port Filters if not using any rule ?
Set to no if the Web Filter is all you want.

If you need additional Port Filters, create a second rule which applies only Port filter Rules.

I noticed it your using both in one rule it won't work. At least for me.  ;)

Well valid point for number one, but I unchecked the Advanced Port Filters option and tested it again, it still does not filter out my test web-pages. Do I need to perform a reboot of the router after unchecking this option? I simply edited the policy, unchecked it, saved, then tested a web-site I've got listed that I should not have access to, but do. So I tried it, but it fails still.

Thank you.
Logged

EddieZ

  • Level 10 Member
  • *****
  • Posts: 2495
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #3 on: May 16, 2009, 04:37:05 PM »

Well valid point for number one, but I unchecked the Advanced Port Filters option and tested it again, it still does not filter out my test web-pages. Do I need to perform a reboot of the router after unchecking this option? I simply edited the policy, unchecked it, saved, then tested a web-site I've got listed that I should not have access to, but do. So I tried it, but it fails still.

Thank you.

Sometimes a reboot helps although it might not be required...
Logged
DIR-655 H/W: A2 FW: 1.33

aln688

  • Level 1 Member
  • *
  • Posts: 18
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #4 on: May 16, 2009, 04:40:56 PM »

Sometimes a reboot helps although it might not be required...

Hmm, I tried it, still no luck. I noticed you have firmware 1.31, although hardware A2. Does Web filtering work for you? Simply setting up a policy as I did and blocking, say, doubleclick.net?

Thanks.
Logged

EddieZ

  • Level 10 Member
  • *****
  • Posts: 2495
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #5 on: May 16, 2009, 04:51:32 PM »

Do you have the router configured as AP?

This was in my logs:
[INFO] Sun May 17 01:51:12 2009 Policy test started; Internet access for MAC address xxxxxxxxxx changed to: Allowed, Web Sites - Restricted, Logged, Ports - Restricted
[INFO] Sun May 17 01:51:12 2009 Internet access for MAC address xxxxxxxxxxx set to: Allowed, Web Sites - None Blocked, Ports - None Blocked
[INFO] Sun May 17 01:51:12 2009 One or more Internet access policies are in effect. Internet access will be restricted according to these policies
« Last Edit: May 16, 2009, 04:54:22 PM by EddieZ »
Logged
DIR-655 H/W: A2 FW: 1.33

aln688

  • Level 1 Member
  • *
  • Posts: 18
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #6 on: May 16, 2009, 04:54:17 PM »

What is "AP"?
Logged

EddieZ

  • Level 10 Member
  • *****
  • Posts: 2495
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #7 on: May 16, 2009, 04:54:57 PM »

What is "AP"?

Access point only. This means DHCP turned off.
Logged
DIR-655 H/W: A2 FW: 1.33

aln688

  • Level 1 Member
  • *
  • Posts: 18
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #8 on: May 16, 2009, 05:01:56 PM »

Oh, no, DHCP is turned on to dish out IPs to the three PCs on my network. Technically it doesn't need to be on, a fixed static address is suitable enough, it's just I've used DHCP as the default.
Logged

EddieZ

  • Level 10 Member
  • *****
  • Posts: 2495
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #9 on: May 16, 2009, 05:04:11 PM »

Oh, no, DHCP is turned on to dish out IPs to the three PCs on my network. Technically it doesn't need to be on, a fixed static address is suitable enough, it's just I've used DHCP as the default.

Just checking  ;D

I did make a policy but did not notice any blocking....I'll try again tomorrow.
Logged
DIR-655 H/W: A2 FW: 1.33

aln688

  • Level 1 Member
  • *
  • Posts: 18
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31
« Reply #10 on: May 16, 2009, 05:06:51 PM »

Just checking  ;D

I did make a policy but did not notice any blocking....I'll try again tomorrow.

Thank you, I'd appreciate to know the results. The fact your logs state the word "blocking" means it's getting further than my router. My logs don't really state that much, certainly nothing to do with "allowed", "blocking" or such keywords.
« Last Edit: May 16, 2009, 05:25:51 PM by aln688 »
Logged

lizzi555

  • Level 5 Member
  • *****
  • Posts: 605
Re: D-Link DIR-655, Web filtering problem with Firmware 1.31 (HOW TO)
« Reply #11 on: May 17, 2009, 12:21:08 AM »

I'm running A2 with 1.31NA too.

Tried with a simple Webfilter:



Created a access rule:



DIR-655 restarted automatically and applied the rule:



And here the result if I try to open the D-Link Website:


Restart is needed as the router only blocks new connections after the rule is applied.
« Last Edit: July 18, 2013, 10:23:02 AM by FurryNutz »
Logged