• February 28, 2020, 06:31:29 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Can't connect to own PPTP-server  (Read 5410 times)

PeterWelzien

  • Level 1 Member
  • *
  • Posts: 5
Can't connect to own PPTP-server
« on: June 22, 2013, 01:07:53 AM »

Hardware version: A5
Firmware version: 1.37EU
Location: Sweden

I'm running a PPTP server. Recently I've switched to a D-Link DIR-655 router and I can no longer connect to my PPTP server.

Under "Virtual servers" I've configured port 1723 and protocol type 47 to be forwarded to my server. Under "Firewall" / "ALG" I've checked PPTP.

I had no problem connecting with my old router. And I can connect to the PPTP server if I'm on the same LAN. So I'm pretty sure that the router is the problem.

Is there something else I need to configure in the router to get it working?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48391
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Can't connect to own PPTP-server
« Reply #1 on: June 22, 2013, 11:15:14 AM »

Link>Welcome!
  • Are you wired or wireless connected to the router?
  • Has a Factory Reset been performed?
  • Was a Factory Reset performed before and after any firmware updates?
  • Was the router working before any firmware updates?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Router and Wired Configurations
Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router.
  • Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options, Advanced/QoS or Gamefuel.
  • Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
  • Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual.
  • Turn OFF or ON DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench
  • Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
  • Ensure devices are set to auto obtain an IP address.
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.
  • Turn off WISH, and WPS under Advanced.
  • Set current Time Zone, Date and Time. Use an NTP Server feature. Tools/Time.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

PeterWelzien

  • Level 1 Member
  • *
  • Posts: 5
Re: Can't connect to own PPTP-server
« Reply #2 on: June 26, 2013, 12:50:54 PM »

Turning off QoS helped. Thanks!

It's strange though that it stops working when QoS is on. Even though there's no active rules or automatic classification.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48391
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Can't connect to own PPTP-server (RESOLVED)
« Reply #3 on: June 26, 2013, 12:56:16 PM »

Interesting. Not sure about what QoS behavior is with PPTP. I know that disabling uPnP effects how Port Forwarding works. Well, hope this fixes it. Keep us posted on how it goes.

Enjoy.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

PeterWelzien

  • Level 1 Member
  • *
  • Posts: 5
Re: Can't connect to own PPTP-server
« Reply #4 on: June 26, 2013, 10:16:26 PM »

And now it's no longer working. Strange.

I'll have to do some more tests tonight.
Logged

PeterWelzien

  • Level 1 Member
  • *
  • Posts: 5
Re: Can't connect to own PPTP-server
« Reply #5 on: June 27, 2013, 01:13:20 PM »

Aha. I apparently need to disable "Traffic shaping" as well.

Now it should be working.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48391
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Can't connect to own PPTP-server
« Reply #6 on: June 27, 2013, 01:59:46 PM »

Keep us posted on how it goes.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

PeterWelzien

  • Level 1 Member
  • *
  • Posts: 5
Re: Can't connect to own PPTP-server
« Reply #7 on: July 05, 2013, 01:06:33 PM »

It's not working. I've managed to connect to my server once or twice. But now I can't anymore. I've tried all your suggestions, nothing helps. SOMETIMES I get the message "Dropped GRE packet from x.x.x.x to y.y.y.y as unable handle packet header" in the log, but not at every attempt.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48391
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Can't connect to own PPTP-server
« Reply #8 on: July 05, 2013, 02:29:45 PM »

I recommend that you phone contact D-Link support, ask for level 2 or higher and see if they can help you with this.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!