• October 26, 2020, 04:10:32 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Installing a Western Digital Green 3TB Harddrive  (Read 2495 times)


  • Level 1 Member
  • *
  • Posts: 1
Installing a Western Digital Green 3TB Harddrive
« on: June 06, 2013, 04:45:53 PM »

Hi Everyone

I have a problem...and I've tried everything!!

I'm running a ShareCentre DNS-320L and have just installed a new WD 3TB Green Harddrive (which is on the capability list). I cannot get the drive to format. It detects the new drive and when you select "Format the new drive as Standard type" The initalize process works, but when it starts to format it hangs at 0%.

WHen you try and navigate around the UI after selecting cancel, my other WD 1TB drive is not shown anymore. You can't access it from the network, you can't see it in the file browser and the status bar is missing from the left for this drive. It actually says "None Hard Drives". When you restart the ShareCentre, the 1TB drive comes back. I have tried formatting the new disk with the 1TB removed as well.

I have tried the harddrive through USB to my laptop and it works fine.

Is there any other way have formatting it to the same type as the SHareCentre accepts? Is it EXT3? Can I use a Linux machine to format it and does anyone know how to do this?

Also, could it be the firmwave version. I'm using 2.03, but can't seem to downgrade back down to try it there?

Any help would be very much appreciated. I would like to get my system up and running as soon as possible.


Andy (Solihull, Nr Birmingham, UK)


  • Level 2 Member
  • **
  • Posts: 34
Re: Installing a Western Digital Green 3TB Harddrive
« Reply #1 on: June 06, 2013, 11:28:15 PM »


I have the same hard drive, and it runs without any problems. My main concern is your firmware. Where did you get version 2.03? As far as I know, the latest official firmware for the DNS-320L is 1.02b07. Maybe you installed firmware for the DNS-320, which is an older model. If that's the case, then you need to install the correct firmware on the NAS.


  • BETA Tester
  • Level 15 Member
  • *
  • Posts: 12190
  • D-Link Global Forum Moderator
    • FoundFootageCritic
Re: Installing a Western Digital Green 3TB Harddrive
« Reply #2 on: June 07, 2013, 05:50:14 AM »

Do you own a DNS-320 or DNS-320L? The DNS-320 is the only D-Link NAS currently supporting a firmware v2.03 release.
« Last Edit: June 07, 2013, 05:54:32 AM by JavaLawyer »
Find answers here: D-Link ShareCenter FAQ I D-Link Network Camera FAQ
There's no such thing as too many backups FFC