• December 12, 2019, 01:00:40 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]

Author Topic: Disable SMB for Macs only  (Read 11937 times)

priitv8

  • Level 3 Member
  • ***
  • Posts: 252
Re: Disable SMB for Macs only
« Reply #15 on: December 01, 2012, 09:13:21 PM »

When I navigate to /mnt/HD/HD_a2  I only see the FFP dir and the shares I have created, but no OEM OS files.  :(
That's 3 levels too deep! you need to back out to / !! There you will see etc alongside mnt and bunch of others.
Logged

hardworking

  • Guest
Re: Disable SMB for Macs only
« Reply #16 on: December 01, 2012, 11:31:53 PM »

Ahh!  Sorry - yes... I was getting confused as to where I was in the tree.  LOL!!

OK... I still don't have an /etc/avahi folder though!

I have done a fair bit of reading, but can't work it out.  The 320L supports AFP out of the box, I just wished I could get rid of SMB.  :(
« Last Edit: December 02, 2012, 12:16:19 AM by hardworking »
Logged

priitv8

  • Level 3 Member
  • ***
  • Posts: 252
Re: Disable SMB for Macs only
« Reply #17 on: December 02, 2012, 01:26:06 AM »

OK, seems the OS version on 320L is a bit newer than on mine (325) and the location of the files might have changed.
SSH as root into command line and run the following command:

find / -name "samba.service" -print

And see if you can spot the location
Logged

hardworking

  • Guest
Re: Disable SMB for Macs only
« Reply #18 on: December 02, 2012, 01:27:34 AM »

Hmm... I got this reply...

root@Moses:/# find / -name "samba.service" -print
/mnt/root/etc/avahi/services/samba.service
find: File system loop detected; `/mnt/HD/HD_a2/squeeze' is part of the same file system loop as `/'.
Logged

priitv8

  • Level 3 Member
  • ***
  • Posts: 252
Re: Disable SMB for Macs only
« Reply #19 on: December 02, 2012, 01:35:19 AM »

OK, then you will rm the samba.service from /mnt/root/etc/avahi/services/ and cp your afp.service to the same place. MC makes it easier with F8 and F5 and visual feedback.
Seems that squeeze has created a circular reference in your filesystem. Why, whether it will hurt you later and how to fix, I unfortunately have no answer at the mo.
Logged

hardworking

  • Guest
Re: Disable SMB for Macs only
« Reply #20 on: December 02, 2012, 01:42:58 AM »

Ok - So far so good.

So I created a file called afp.service in /mnt/root/etc/avahi/services

I used the text you supplied!!  YIPPEE!!

You are a legend!!

I just checked with Get Info and I am not connecting using AFP!

THANK YOU SO MUCH!!!

How did you get the funky icon though?  Mine still shows a dodgy screen icon.
Logged

priitv8

  • Level 3 Member
  • ***
  • Posts: 252
Re: Disable SMB for Macs only
« Reply #21 on: December 02, 2012, 02:27:57 AM »

How did you get the funky icon though?  Mine still shows a dodgy screen icon.
That's the model=Xserve key in _device-info._tcp that Finder knows how to interpret.
<service>
   <type>_device-info._tcp</type>
   <port>0</port>
   <txt-record>model=Xserve</txt-record>
</service>


Try to restart Finder or sign off and back on.
You might also check under Network how does it show.
I have the 10.8.2 and it displays the correct device icon as soon as I copy afp.service to Avahi.
Logged

hardworking

  • Guest
Re: Disable SMB for Macs only
« Reply #22 on: December 02, 2012, 02:36:26 AM »

Hi,

Thanks.  Yeah not sure why it's not working.  Not too concerned, as it comes up at least.  :)

Here is what I get.  My NAS is called Moses.  (Don't ask)  LOL!!!

EDIT - SCRATCH THAT!!  It just changed!  Woo hoo!

Again... thanks mate!

Now I have everything running perfectly.

Cheers
John
Logged

hardworking

  • Guest
Re: Disable SMB for Macs only
« Reply #23 on: December 06, 2012, 02:59:29 PM »

Hmm... Just found out if I reboot the NAS, it dumps the new AFP.SERVICE and re-installs the Samba.Service.

Is this normal, and is there a way to fix this?

Cheers
John
Logged

priitv8

  • Level 3 Member
  • ***
  • Posts: 252
Re: Disable SMB for Macs only
« Reply #24 on: December 08, 2012, 07:49:50 AM »

Yes, that's what I said a week ago:
To make this excercise survive reboot, you would need to find where /etc/avahi/services is stored on FLASH device and copy the file there (should be quite along the lines of store-password.sh from nas-tweaks), but I haven't bothered with this yet. I keep my NAS on 24/7.
Problem is, NAS reloads all config files fresh from Flash storage during reboot.
Logged

hardworking

  • Guest
Re: Disable SMB for Macs only
« Reply #25 on: December 08, 2012, 03:18:49 PM »

Ahh.  I see - I didn't quite follow that last post, but I get it now.

So this would be an easy fix!  I have some other things running in a script at startup for Squeeze such as Sickbeard and SabNZBD.  I could have it copy the afp.service to the folder, and then delete the samba file.

That might work.  :)
Logged
Pages: 1 [2]