• September 21, 2019, 11:01:16 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Why does DSM-520 play some MP3 files and not others?  (Read 7932 times)

p23185

  • Level 2 Member
  • **
  • Posts: 39
Why does DSM-520 play some MP3 files and not others?
« on: April 18, 2009, 06:24:57 PM »

I really like the media lounge and have tried to listen to some of my MP3 audio collection out in the family room.  BUT there is something amiss and I am wondering if anyone knows what the problem might be or what tool I could use to find out if my MP3 files are "incorrectly formatted".  All these files play just fine on any of my 3 PCs (Win XP and Vista), but not on the media lounge.  Here is a picture of what the files consist of.

WILL NOT PLAY - MEDIA LOUNGE LOCKS UP
General
Complete name                    : K:\media player\audio MP3\Audio_recorded\Audio_recorded-mp#10\frizzel,west_the-david&shelly,album\01wasn't_that_love.mp3
Format                           : MPEG Audio
File size                        : 2.75 MiB
Duration                         : 3mn 9ms
Overal bit rate                  : 128 Kbps
Genre                            : Soundtrack
Recorded date                    : 0001

Audio
Format                           : MPEG Audio
Format version                   : Version 1 / Layer 3
Duration                         : 3mn 9ms
Bit rate mode                    : CBR
Bit rate                         : 128 Kbps
Channel(s)                       : 2 channels
Sampling rate                    : 44.1 KHz
Resolution                       : 16 bits
------------------------------------------------
PLAYS FINE ON MEDIA LOUNGE

General
Complete name                    : K:\media player\audio MP3\Audio_recorded\Audio_recorded-mp#10\bandy,moe_barroom-roses\01tonight_she_went_crazy_without_me.mp3
Format                           : MPEG Audio
File size                        : 2.76 MiB
Duration                         : 3mn 741ms
Overal bit rate                  : 128 Kbps
Genre                            : Genre_232
Recorded date                    : 0001

Audio
Format                           : MPEG Audio
Format version                   : Version 1 / Layer 3
Duration                         : 3mn 740ms
Bit rate mode                    : CBR
Bit rate                         : 128 Kbps
Channel(s)                       : 2 channels
Sampling rate                    : 44.1 KHz
Resolution                       : 16 bits
-----------------------------------------------
used
MediaInfo 0.7.7.0
Copyright (C) 2002-2008 Jerome Martinez

Supply very detailled information
about a multimedia file:
Matroska, OGG (including OGM)
MPEG1 (including VCD)
MPEG2 (including DVD and SVCD)
MPEG4 (including Itunes M4A)
Quicktime
RealMedia
WindowsMedia (including WMV, WMA)
Microsoft RIFF (including AVI, WAV)
Sound-only formats (AC3, DTS, AAC, AU, AIFF...)

I coded these files from old 33 rpm records a few years back and while I cannot remember for sure, I think they all used the encoder that I purchased a license from Nero.   I'm thinking either of these might be a problem??
1) I don't have enough information as to the guts of the files, anyone know another tool to use
2) Maybe the DSM-520 cannot read the directory path?  Why would it lock up?  It displays the folder and tracks properly and when pressing play - lockup and only way to shut down is with the swtich on the unit - remote is useless.
Logged

fccgrant

  • Level 2 Member
  • **
  • Posts: 77
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #1 on: April 20, 2009, 10:28:18 AM »

I have no idea so we'll just wing it here.

The only differece I see is that the first file has an apostrophe in the file name.  Try copying it and naming it something different  like test.mp3 and see if it will play.  Perhaps the media server software that you are using doesn't like the apostrophe in it.

BTW...which media server software are you using?
Logged

p23185

  • Level 2 Member
  • **
  • Posts: 39
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #2 on: April 22, 2009, 09:17:26 PM »

DSM-520 Media Lounge is running ver 1.06 - I don't use the Dlink Media Server which is installed on my PCs.  When using the media lounge I acces the DNS-323 media files through the wireless link - DNS-323 has a UPnP AV server which works fine for all the video files I have.  Don't know if UPnP AV Server might present a problem with certain audio tracks - but out 3,600 audio mp3 tracks many work just fine.  I am struggling to find the difference in how these folders end up with different mp3 files.

The files are located on a D-Link DNS-323 which is running ver 1.04

I can try renaming the track, but the media lounge locked up big time when I talso ried the 2nd track in that folder, named "02two_sides.mp3"
Logged

fccgrant

  • Level 2 Member
  • **
  • Posts: 77
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #3 on: April 23, 2009, 10:31:02 AM »

I don't know anything about the DNS-323 but hopefully someone else can chime in here.

My first thought is to check to see if there is any naming rules.  Could have been some sort of rule prior to version 1.04 firmware on the DNS.

My next thought is that if the DNS is pulling the files from a PC then I would check to see if there are any permissions on the file or directory is set especially if one of your systems is running XP Professional.

I thought maybe the length of the file location was too long but the one that doesn't play is shorter than the one that will.

How were you playing the file when testing on the 3 PC's?  Windows Media Player?
Logged

p23185

  • Level 2 Member
  • **
  • Posts: 39
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #4 on: April 23, 2009, 10:37:30 AM »

DNS is not pulling anything from the PC.  The PC is turned off and the media lounge is pulling the files from the DNS-323 Network Attached Storage device.
Logged

ECF

  • Poweruser
  • Level 11 Member
  • *
  • Posts: 2692
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #5 on: May 01, 2009, 08:31:10 AM »

I would recommend updating the firmware on the DNS-323. That firmware is over a year old and I believe I remember that being an issue in past firmware when using these two devices.
Logged
Never forget that only dead fish swim with the stream

p23185

  • Level 2 Member
  • **
  • Posts: 39
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #6 on: May 07, 2009, 08:54:27 PM »

I would recommend updating the firmware on the DNS-323. That firmware is over a year old and I believe I remember that being an issue in past firmware when using these two devices.

I updated F/W to the latest 1.07.  Still get the lockup on certain tracks. Oh, well - wish I could find a tool that would inspect the differences of a track that works and one that doesn't.  BUT like I said earlier I am quite sure I used the same encoder and bit rates,sample rates, etc to make the original tracks.
Logged

p23185

  • Level 2 Member
  • **
  • Posts: 39
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #7 on: May 13, 2009, 10:39:16 PM »

After updating to f/w ver 1.07, I noticed that under the UPnP AV Server there no longer appears to be a box to select how frequently to have the AV server refresh.  Is it now just on a manual basis?
Logged

ECF

  • Poweruser
  • Level 11 Member
  • *
  • Posts: 2692
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #8 on: May 19, 2009, 04:56:18 PM »

It now uses a inotify Linux kernel subsystem that allows the UPnP AV media server it index files as they are added. It no longer needs to scan the whole folder every time something is added. It is still a good idea to refresh the folder if you change the folder that the UPnP AV media server is looking at.
Logged
Never forget that only dead fish swim with the stream

p23185

  • Level 2 Member
  • **
  • Posts: 39
Re: Why does DSM-520 play some MP3 files and not others?
« Reply #9 on: May 24, 2009, 11:47:33 AM »

Thanks - I notice that it is updating automatically.
Logged