• October 29, 2020, 04:38:49 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DIR-655 as a hop router - no dhcp passing through.  (Read 2447 times)


  • Level 1 Member
  • *
  • Posts: 1
DIR-655 as a hop router - no dhcp passing through.
« on: February 25, 2018, 06:57:24 AM »

Hello, another DIR-655 user here.
So I've upgraded my base router at home to a netgear nighthawk and wish to continue using the d-link 655 as an extension of my home network due to its decent wifi coverage.  I am not new to networking at all and this router has me at my wits end.  The layout is simple:

main router/gateway:
DHCP enabled: -

dlink router:
Hardware Version: C1     Firmware Version: 3.02
uplink is in port 1

Dlink is pingable and routing traffic from base router.

The problem is, the dlink does not distribute dhcp addresses from the main router on wired connections.  Anything hard wired to the dlink continues to pull 169 addresses.  I don't think this was an issue prior to the latest firmware update, but I didn't need to wire anything in to it prior.

Troubleshooting: Wireless works no problems, I've verified by changing the SSID, releasing addresses and renewing them.  Even clearing the dhcp leases on the base router between changes.  Devices get wifi addresses without an issue. 
I've gone through every menu on the dlink, even went back to factory settings and set up from scratch.  Continue to get same results. 
I can set a static IP outside the dhcp range complete with gateway and wire it in to the dlink and it works no problem. 
I've even gone as far is using an unmanaged 8 port switch, plugged it near the dlink, then from that device, plugged into the dlink.  Devices on that switch pull dhcp.  This is a dumb solution that won't stay long. 
I've also tried a 3rd router (an old linksys) acting as a base router running dhcp and even as the extra hop router with dhcp turned off. 
Even though it was working fine, i've just tried patch cables and a crossover cable even though the nighthawk reverses the port for you if you use the wrong cable anyway. 
I've narrowed it down to the dlink being the issue almost without question.

I'm leaning on the side that this has to be a glitch.


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49296
  • D-Link Global Forum Moderator
    • Router Troubleshooting
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!