• April 02, 2020, 10:46:02 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DSL 2750-U WPS cannot be disabled  (Read 23387 times)

badbuy

  • Level 1 Member
  • *
  • Posts: 7
DSL 2750-U WPS cannot be disabled
« on: November 02, 2012, 08:06:32 PM »

I have intermittent problems with the WPS blue light flashing on the side of the router.

I figured out how to disable it in 'Advanced Wireless -- Security Settings' (I've also read that leaving it enabled is a security risk as hackers can brute force the 8-digit PIN).

However, whenever I change the setting to 'disabled' and click 'Apply/Save', the setting remains enabled after the routers has (supposedly) updated its settings.

Any idea how I can disable this and/or why does the blue WPS light start flashing in the first place?

Any help gratefully received.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48528
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL 2750-U WPS cannot be disabled
« Reply #1 on: November 03, 2012, 03:52:53 PM »

What browser are you using to manages the modem? Try Opera or FF? Will it set and save then?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

badbuy

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL 2750-U WPS cannot be disabled
« Reply #2 on: November 03, 2012, 07:52:44 PM »

Thanks for your reply.

It makes a difference, but doesn't solve the problem. I was having the problem in Safari. When I use Firefox, the page is different and doesn't include the WPS option at all (see screenshots below). I can't find it anywhere else in the setup page either.  ???

A bit stumped now...problem seems to be getting worse, too. Resetting the router seems the only way to stop it, but it's only a temporary fix - after a few hours it starts again.

Safari:




Firefox
« Last Edit: November 03, 2012, 07:55:58 PM by badbuy »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48528
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL 2750-U WPS cannot be disabled
« Reply #3 on: November 03, 2012, 09:57:57 PM »

Does this happen if you try with a Windows PC?
I would contact your local regional D-Link support office and ask for some additional information on this.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

badbuy

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL 2750-U WPS cannot be disabled
« Reply #4 on: November 03, 2012, 10:10:17 PM »

There's pc, mac, ipad, iphone, android...a variety of devices all connected via wifi at the same time.

I haven't tried the router setup page from the pc. I'll try that and see what happens.
Logged

badbuy

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL 2750-U WPS cannot be disabled
« Reply #5 on: November 04, 2012, 03:48:41 AM »

I logged into the router via a pc and same problem (in Ffx, the WPS setting isn't shown; in Chrome it showed, but changing it and hitting Apply/Save didn't have any effect).

I did figure out a way round it, in case anyone comes here looking for a solution to the same problem.

Here's how you turn WPS off:

1. Click on the 'Maintenance' tab.

2. Under System -- Backup Settings click the 'Backup Settings' button.

This will download your routers config file to your hard drive (whatever your default downloads folder is).

3. Open the file with a plain text editor (if you're a terminal fan, vi or emacs will do. If not, Tincta is a great one to use on macs. Sorry, I don't know what you Windows folks use. Notepad?).

4. Search the file for WPS and change the <Enable> setting from 'TRUE' to 'FALSE',

It should look something like this:
 <WPS>
          <Enable>FALSE</Enable>

5. Save the file.

6. Go back to the Maintenance page, and under 'System --Update Settings' hit 'Choose File'.

7. From the dialog, choose the file in your downloads folder that you just edited. Then click 'Update Settings' on the router page.

Wait a couple of minutes for it to update and reset, and you 're done.  ;D


« Last Edit: November 04, 2012, 03:58:17 AM by badbuy »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48528
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL 2750-U WPS cannot be disabled
« Reply #6 on: November 04, 2012, 08:15:47 AM »

Nice information. I would recommend contacting DLink support about this. This seems to be a legitimate bug. Is the FW up to date? Is this a retail modem or one that was supplied by the ISP?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

badbuy

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL 2750-U WPS cannot be disabled
« Reply #7 on: November 04, 2012, 09:29:24 AM »

It was a retail modem. To be honest, I haven't checked for firmware updates (where do I do that? Any ideas?) and I'm unlikely to contact D-Link about it unless the router shows any further problems.

Thanks again for your input and advice. Good to know there are people out there willing to help. :)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48528
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL 2750-U WPS cannot be disabled
« Reply #8 on: November 05, 2012, 09:00:02 AM »

I would contact your local regional D-Link support office, level 2 maybe for FW updates and information.

Good Luck.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!