The Graveyard - Products No Longer Supported > DIR-827

Access Control/schedule bug on 1.03FW

(1/11) > >>

OK, FurryNutz I have a good one for you. This took me a long time to isolate down to this sole issue. I upgraded to the 1.03fw about 2 weeks ago. I attempted to load my saved configuration and noticed the router was not connected to the internet. I logged on the router and saw that all of my DNS and ip addresses were associated, however the connection up time was showing N/A.

I restored factory config, and the internet started working again. Basically through trial and error and a ton of reboots I have isolated the root cause of the router not wanting to pick up my internet connection.

Long story short, I cannot have a defined schedule (i.e.monday-fri 2300~0600) blocking all access with more then 4 IP addresses associated with that schedule under the access control tab. If I have 4 or less, the router works as it should and I have internet access.

The minute I attempt to add a 5th ip address to that access controlled schedule, upon reboot my router shows Connection up time: N/A and I have no internet connectivity.

I tried to isolate it further, and have noted that I can block all access using access control with more than 4 computers as long as I have no user defined schedule, as in I just plain block all access using the ALWAYS setting.

I never had this issue on firmware 1.02. I can load my 1.02 firmware config file, reboot, no connectivity. If I delete any IP address totalling more than 4 per access  controlled schedule, boom I have connectivity. Something is the 1.03 firmware upgrade has broken access control. I tried redownloading 1.03 and the same issue happens.

Can someone else try this and see if there router loses connectivity? My ISP is cablecable, its a wireless broadband with 5mb down and 768k up.

I am curious if this is firmware and router wide or isolated to just me.

Have you factory reset, upgraded FW, factory reset once more then set up the router from scratch and not load any saved configuration file?

What browser are you using when you manage the router?
IP addresses reserved?

I have tried the factory reset route. Part of my troubleshooting step was to:
-factory reset
-leave all settings default
-create test schedule, mon-fri 2300-0600
-enable access control
-apply access control schedule test to 6 ip addresses within my DHCP range (, etc)

This still causes my connection to show N/A and have no connectivity.

I have tried manually reentering parts of my config, with static Ip addresses that I have manually assigned to devices etc and it always fails to connect at greater than 4 ips associated with a given access control schedule.

I am using firefox from a wired lan connection. Setup has been working flawlessly as we speak given I have a maximum of 4 IP's associated to my rule. If i were to log on the router now, add one more ip address, it fails to connect. Something seems fishy. It worked fine on 1.01 and 1.02

On a side note, 1.03 has been rock solid for me while torrenting. No more lock ups!

I will give this a go on my 857 this evening and see if I notice the same thing. This could be isolated to the 827 or across all of the Amplfi lines...

I'll forward this to D-Link and see if they can reproduce as well. If it didn't happend on the other versions and now your getting problems on v1.03, I presume something could be broke.

You could do us a favor and do a factory reset, load v1.02, factory reset, and then configure your access controls again to verify that v1.02 works  and report your results please?

Sure I can try that when I get home this evening when I get home. I will post up my results as soon as I can.


[0] Message Index

[#] Next page

Go to full version