D-Link VPN Router > DSR-250N

Certificate key (PEM) for OpenVPN

<< < (2/3) > >>

FurryNutz:
I would try email support if you haven't done that already. If you dont' seem to get any feedback, let me know and I'll forward this onto D-Link USA here and see if anyone here can help. You might try submitting a email ticket on the U.S. site and see if you get any feedback.

Thiesy:
A few days ago I installed FW 1.05B73 and finally got my openVPN server running. I also am using certificates/keys generate with scripts supplied with the openVPN software for Win from Openvpn.net.

I also experienced the problem you describe.

I solved it with the free software from Christian Hohnstädt at http://xca.sourceforge.net/

I imported the key and exported it into PEM format using the PKCS#8 option. The generated file worked with the above FW.


Jörg

nickaardo:
worked for me too...
Thanks for this important tip !

ddywz:
FW version 1.05B73 is posted on german support site of DLink.  Does anyone know if it is ok to upgrade to this version a US based router?  Latest version posted for US is 1.05B20.  Does FW 1.05B73 has an english language menu?

I'd like to setup OpenVPN and I read that only this new version of fw works fine for it.

Thanks,

FurryNutz:
I see that EN and ALL is in the file name. I presume it would work and is in English or has English language UI options. DSR-250N_fw_revALL_1-05B73_all_en_20121112

Read the release notes file for fixes.
I would play it safe, save off the current configruation to file, then do a factory reset, update FW, Factory reset once more then configure the router from scratch. There maybe differences between the FW versions and config files that may warrant a clean setup from scratch.

Let us know how it works for you.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version