• November 19, 2019, 04:30:47 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2

Author Topic: DIR-865 loses saved admin password on reboot  (Read 18244 times)

rlcronin

  • Guest
DIR-865 loses saved admin password on reboot
« on: August 16, 2012, 06:40:43 AM »

As previously reported, sometimes when I reboot my 865, when it comes back up it has forgotten the admin login password I previously set and has reverted back to blank. I had previously thought this only happened when rebooting after restoring a saved configuration. However, yesterday I changed turned on IPV4 multicast streams (to fix a problem with AirPrint) and had to reboot to activate it. Sure enough, after the reboot the password I had previously saved no longer worked and I had to supply blanks to get logged in.

It seems a fairly serious security issue to me if the password is going to randomly get reset to blanks.
--
bc
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-865 loses saved admin password on reboot
« Reply #1 on: August 16, 2012, 07:05:10 AM »

What FW version is currently loaded?
What browser are you using when this happens? Happen if you use IE?
Have you cleared the browser cache?
Does this happen on more than one PC?

Have you done a factory reset along with clearing the browser cache and then set up something on the router and then have it reboot?

Please review this:
http://forums.dlink.com/index.php?topic=50314.0
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

rlcronin

  • Guest
Re: DIR-865 loses saved admin password on reboot
« Reply #2 on: August 16, 2012, 10:12:04 AM »

What FW version is currently loaded?
What browser are you using when this happens? Happen if you use IE?
Have you cleared the browser cache?
Does this happen on more than one PC?

Have you done a factory reset along with clearing the browser cache and then set up something on the router and then have it reboot?

Please review this:
http://forums.dlink.com/index.php?topic=50314.0
1.01
Chrome, I refuse to use IE
I clear my browser cache every time I close it (multiple times a day, yes I am compulsive)
Not sure, I tend to reboot the router from the PC that the router sits next to

This litany of questions smacks of a helpdesk script intended to tire out the user so they'll stop complaining and you won't have to fix a problem ;-)
--
bc
Logged

rlcronin

  • Guest
Re: DIR-865 loses saved admin password on reboot
« Reply #3 on: August 16, 2012, 10:15:23 AM »

Please review this:
http://forums.dlink.com/index.php?topic=50314.0

Oh and as regards this advice, could you please explain how the router forgetting the password I configured after weeks of it working fine and simply rebooting the router could possibly have anything whatsoever to do with what browser I initiated the reboot from? This sounds like a myth. I'd like some factual basis for the claims, please.
--
bc
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-865 loses saved admin password on reboot
« Reply #4 on: August 16, 2012, 10:26:18 AM »

I would ask you to give IE and or FF a try and test this out. Many variables with Chrome that maybe causing issues with the router. Just the other day a guy bricked his 835 while upgrading FW using Chrome. We have seen other problems in using Chrome as a router management tool. Please consider trying IE and or FF and let us know the results.

Unfortunately the 865 isn't available at a store here yet or I would go try one out and test this myself.  ::)
« Last Edit: August 16, 2012, 10:37:35 AM by FurryNutz »
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-865 loses saved admin password on reboot
« Reply #5 on: August 16, 2012, 10:27:18 AM »

I would also contact DLink support, level 2 or higher and talk to them about this.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-865 loses saved admin password on reboot
« Reply #6 on: October 03, 2012, 10:10:20 AM »

Hows your 865L doing?  ???
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

rlcronin

  • Guest
Re: DIR-865 loses saved admin password on reboot
« Reply #7 on: October 04, 2012, 10:23:03 AM »

Hows your 865L doing?  ???
Stable, but still with the various issues I mentioned (but none are showstoppers).
--
bc
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-865 loses saved admin password on reboot
« Reply #8 on: October 04, 2012, 12:57:57 PM »

We still waiting on release day here.  ::)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

rlcronin

  • Guest
Re: DIR-865 loses saved admin password on reboot
« Reply #9 on: October 06, 2012, 07:13:44 AM »

Hows your 865L doing?  ???
So remember my DNS Relay issue? If I disable DNS relay and configure static DNS servers in the router's Internet Settings dialog (pointing to OpenDNS), while my PC's would get the correct set of DNS servers (the two OpenDNS ones and two from my ISP), all of their DNS lookups would timeout.

Well, since I had been running with DNS Relay ON as a workaround and I'd been having problems with OpenDNS sometimes not being used (going to welcome.opendns.com would claim I wasn't using OpenDNS despite the fact my static DNS servers in the router were pointing to OpenDNS), I was getting desperate for a real solution. So, I researched it a bit more last night and came across some information suggesting that turning off SPI (in Firewall Settings) would help. I just tried that and indeed it worked.

So, something about DNS Relay being off causes DNS conversations to be subjected to SPI and something in the router's SPI processing causes DNS queries to never complete. I saw a suggestion that the bug may have something to do with modern DNS queries requiring more than 512 bytes and speculation that the router fails to allocate more than that. I'm not expert in these matters by any means, so this explanation may not be 100% spot-on, but if I were a Dlink firmware engineer I'd use it as a clue as to where to start looking.

I regret that this morning I can't find the exact article that I found the SPI clue in. It was a well researched and very detailed account of a Dlink router's behavior in all the possible configuration states (relay on, relay off, SPI on, SPI off, etc.). I found it by searching Google for "DLINK DNS RELAY PROBLEM" and then just wading through the (many, many) hits. Apparently this issue goes back years and years and affects nearly every Dlink router, ever! On some routers there was no interaction with SPI (i.e. tunring off DNS relay was enough to fix it), but on others you also had to turn off SPI. Based on my results, it seems the 865L is one of those.

While I am happy to have found a way to get DNS working properly with this router, I am discouraged that this problem has been around so very long and that Dlink can't fix it once and for all. Further, I am not certain I want to run with SPI off for any length of time, so now I have to decide whether I want move on to some other router or not. I think I will run off to BestBuy today to pickup a competitor's router to test (and return if it doesn't pan out).
--
bc
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-865 loses saved admin password on reboot
« Reply #10 on: October 06, 2012, 09:47:41 AM »

If you happen to cross that article again, it would be helpful to get a review of it. Did you happen to notice the date of th article?

I would agree that there could be an issue with DNS and SPI, however in most uses of SOHO routers, generally most uses are going to be using default ISP DNS and leaving the router in default settings, however given the fact that options are available in the router to set up using other DNS, realistically it should work well using default or custom settings with SPI and DNS Relay ON or OFF.

I have been running custom DNS addresses using Name Bench from Google as I primary and secondary for finding faster DNS. DNS Relay has been OFF. However I do notice that sometimes on my Mac Book Pro and using Opera, that when I open pages to the web, Opera seems to be still trying to load or complete and come to a full stop when loading pages. Not sure if this could be related to this or the WiFi. Generally it works most of the time so I believe its a Wifi issue.

As for this DNS Problem, there could be other factors leading to it, ISP services, ISP modem setup and configuration and how did they come to the conclusion of this "DLINK DNS RELAY PROBLEM"? I believe there are other variables that could lead to false positives.

We are currently monitoring a problem between one Canadian ISP and a DIR-835. Seems that YouTube and other sites are not working well with these two configurations. I have verified that here in the U.S., the problem does not exist a I went and bought the 835 and tested it out and then returned the router. Seems like we see some odd ball issues always with Canadian ISPs and these routers.

I wish the 865L was on sale here so I could test this out. One thing you could do, try taking the router to a different place, friend, family or someone who's is on a different ISP and Modem. See if the problem follows. Would be a good test and let you know more about it. I supposed I can test it out on a couple of routers I got here. If you can either post or PM me some exact details of setting up the router and steps you take, would be helpful. I just got an ol DIR-685 to test out. Will see if I exhibit this DHCP Reservation issue they are seeing over on that board even though the poor thing is EOL.

I'll pass this along to D-Link so they so. Please keep us posted on your results with the 865L and a different Mfr router. And if you come across that article, please post it.

Have a good weekend.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-865 loses saved admin password on reboot
« Reply #11 on: October 06, 2012, 11:35:25 AM »

we should probably start a new thread on this...Want to start a new post?
Did the article happen to be on DSLreports or Broadbandreports?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

rlcronin

  • Guest
Re: DIR-865 loses saved admin password on reboot
« Reply #12 on: October 06, 2012, 11:36:44 AM »

I doubt this has anything to do with the ISP, but for the record, my ISP is CableVision in Dutchess County NY. The modem is an Arris TM802G running firmware TS0703123_090611_MODEL_7_8. The connection is rated at 50/8, but consistently delivers 60/8.

As near as I can tell, the minimum router settings to recreate this are:

On the Manual Internet Connection Setup page:

Internet connection: Dynamic IP (DHCP)
Primary DNS Server: 208.67.222.222
Secondary DNS Server: 208.67.220.220

On the Network Settings page:

Enable DNS Relay is UN-CHECKED
Enable DHCP Server is CHECKED

On the Firewall Settings page:

Enable SPI is CHECKED

When my PC requests an IP address it gets:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) 82583V Gigabit Network Connection
   Physical Address. . . . . . . . . : 54-04-A6-3C-DC-B3
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::cdc5:4a91:5a8d:915d%16(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, October 05, 2012 10:24:32 AM
   Lease Expires . . . . . . . . . . : Tuesday, November 12, 2148 8:58:52 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 424936614
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-40-DA-0C-20-CF-30-4F-F3-B7
   DNS Servers . . . . . . . . . . . : 208.67.222.222
                                       208.67.220.220
                                       167.206.251.129
                                       167.206.251.130
   NetBIOS over Tcpip. . . . . . . . : Enabled

If I then open a command prompt and do (say) ping google.com, ping sits there for quite some time doing nothing and eventually times out, saying it cannot resolve the address.

If I then UN-CHECK Enable SPI and issue

ipconfig /release
ipconfig /flushdns
ipconfig /renew

from the PC and issue the same ping command, it works.
--
bc



Logged

rlcronin

  • Guest
Re: DIR-865 loses saved admin password on reboot
« Reply #13 on: October 06, 2012, 11:37:23 AM »

we should probably start a new thread on this...Want to start a new post?
Did the article happen to be on DSLreports or Broadbandreports?
I'm sorry, I forget. I'll need to try to find it again ...
--
bc
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-865 loses saved admin password on reboot
« Reply #14 on: October 06, 2012, 11:50:29 AM »

FYi,
Seen some various issue with Arris Modems.

Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting
Pages: [1] 2