• August 12, 2020, 07:54:53 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3

Author Topic: Oops! Page on DIR-857  (Read 24885 times)

rgarri

  • Level 1 Member
  • *
  • Posts: 2
Oops! Page on DIR-857
« on: May 26, 2012, 10:22:20 AM »

I have been intermittently seeing the Oops! page when browsing the web.
The problem is less often with the new 1.01 firmware, but still annoying.

I know the sites I am going to are up. Google, Gmail, etc. 80%+ of the pages I am going to will work.

When it gets really bad, the internet speeds also go down through the router (under 1mbs). When I connect directly to the cable modem, I get 35-40mbs.

Sometimes CTRL + F5 clears it up. Sometimes I need to reboot the router.

It is a D-link page, with a dumb little picture suggesting that I am not connected to the internet. I would rather just see the normal url, and 404 page if indeed the page was down.

How can I disable the Oops page?

I did not run into this problem on my DGL-4500. I am debating about using the 4500 as a WIRED router, and then setting up the 857 as an access point in my house to use the incredible range and dual band.

Probably worth of separate forum post: If I used the DIR-857 as a wireless access point, would I still be able to access the 3.0 USB from the other devices on my wired and wireless network?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49059
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Oops! Page on DIR-857
« Reply #1 on: May 26, 2012, 10:28:22 AM »

Welcome!

What region are you located?

What ISP Service do you have? Cable or DSL?
What ISP Modem do you have? Stand Alone or built in router?
What ISP Modem make and model do you have?
If this modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems.
To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged.
If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ.

Some things to try:
Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking.


Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.
Turn off all devices accept for one wired PC while testing.

Check cable between Modem and Router, swap out to be sure. Cat6 is recommended.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Beeder

  • Level 2 Member
  • **
  • Posts: 65
Re: Oops! Page on DIR-857
« Reply #2 on: May 29, 2012, 11:08:43 AM »

I believe that Oops would be related to DNS.  Perhaps your ISP's DNS is having issues (I had trouble with Comcast a while back on the DGL-4500, and I remember seeing the DLink Oops when it happened).  Try setting the DNS to the free Google servers and see if it goes away...?
Logged

sleepness

  • Level 1 Member
  • *
  • Posts: 2
Re: Oops! Page on DIR-857
« Reply #3 on: May 29, 2012, 01:43:29 PM »

The problem is most likely DNS, as the poster said.  Try downloading the new firmware.  I had the same annoying issue (using both Google's DNS as well as Comcast's) which went away after downloading the firmware.  Firmware also seemed to speed my router up quite a bit.
Logged

seraph

  • Level 1 Member
  • *
  • Posts: 7
Re: Oops! Page on DIR-857
« Reply #4 on: June 03, 2012, 10:53:30 AM »

I'm getting this as well on my DIR-857. 

I've seen it mostly on DNS names that once existed, but no longer resolve or don't currently resolve.  Instead, an nslookup resolves to the router's internal IP.

If I disable DNS relay feature, the problem seems to go away.  An nslookup on the same DNS names now returns DNS timed-out.

This appears to be an issue with the DNS Relay's handling of a DNS time out.  I'd like to keep the DNS relay feature left on, but not if I can't disable this page.

In response to Beeder.  I also upgraded to the DIR-857 from a DGL-4500 and my ISP is RCN.  The DGL-4500 never exhibited this behavior with DNS relay enabled.  This only started when I switched to the DIR-857.  Hoping for a fix, I also upgraded from firmware 1.00 to 1.01, and the problem exists on both firmwares.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49059
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Oops! Page on DIR-857
« Reply #5 on: June 03, 2012, 06:26:05 PM »

Try using manual DNS entries under Setup/Internet/Manual. Try using other ISP DNS or Google. I would recommend using NameBench as well to find other ISP DNS. This is DNS releated and the OOPs page is the router telling you that there is a problem upstream from the router.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

seraph

  • Level 1 Member
  • *
  • Posts: 7
Re: Oops! Page on DIR-857
« Reply #6 on: June 03, 2012, 07:48:29 PM »

My DNS settings are already manually set.  My ISP's DHCP server feeds residential customers DNS servers that hijack NXDomain, which to me is unacceptable, and there is no way to disable that "feature".  To bypass this, I manually set the DNS servers they feed to business customers, since these do not hijack NXDomain returns.

For sake of due diligence, I also used Google's DNS servers to test, and got the same result.  Domain requests that normally time out, return 192.168.0.1 when DNS relay is enabled and the Oops! page is displayed in my browser.  Again when I turn DNS relay off, the domain requests time out.  In my test case, I used a domain that existed, but is no longer active.  It is still registered, but a DNS query of the domain always times out.

I don't believe that there is a "problem" upstream, since all other DNS queries resolve w/o issue. Rather the DIR-857 is translating a simple DNS timeout as a complete network failure and displaying the Oops! page, when it's only the one address that times out.  I should be able to set DNS relay and have it behave the same as accessing the DNS servers directly.  However, the option to disable the Oops! page seems to be missing.
« Last Edit: June 04, 2012, 06:47:41 PM by seraph »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49059
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Oops! Page on DIR-857
« Reply #7 on: June 04, 2012, 07:28:28 AM »

I would contact your ISP and ask them if they see any issues or can review there logs and see if there is any problems on there side.

BTW, What ISP Service do you have? Cable or DSL?
What ISP Modem do you have? Stand Alone or built in router?
What ISP Modem make and model do you have?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

seraph

  • Level 1 Member
  • *
  • Posts: 7
Re: Oops! Page on DIR-857
« Reply #8 on: June 04, 2012, 06:57:23 PM »

ISP (as always) reports that there is no problem with DNS.

Service type is Cable.
Modem is a Motorola SB6121.  The only router in the setup is the DIR-857.

This issue occurs on wireless and wired clients, but most of the time is intermittent.  As I'm browsing a random domain will bring up the Oops! page.  Yet browsing immediately before and after occurs w/o issue.  If I wait a bit, the affected domain will eventually start working again.  Especially if I run an ipconfig /flushdns to force my system to re-request the DNS information.

As I said in my previous post I came across a domain that always brings up this Oops! page when DNS relay is enabled.  This domain is no longer active.  With DNS relay enabled, it always resolves to the routers internal IP address.  If I turn DNS relay off, then it always times out when I try to run an nslookup, and trying the address in IE gives the expected "Internet Explorer cannot display the webpage."
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49059
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Oops! Page on DIR-857
« Reply #9 on: June 04, 2012, 08:01:16 PM »

Can you post a link to one of these sites that it brings this Oops page up?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Beeder

  • Level 2 Member
  • **
  • Posts: 65
Re: Oops! Page on DIR-857
« Reply #10 on: June 05, 2012, 07:35:11 AM »


What's your MTU set to, btw?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49059
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Oops! Page on DIR-857
« Reply #11 on: June 05, 2012, 07:38:46 AM »

Usually most cable ISPs use 1500. DSL uses 1492-1472.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Beeder

  • Level 2 Member
  • **
  • Posts: 65
Re: Oops! Page on DIR-857
« Reply #12 on: June 05, 2012, 07:41:00 AM »

Thanks for your reply, Furry.

OP, what's your MTU?  If it's too low for your ISP (which it sounds like is a bit goofy from your comments), you'll see Oops.
Logged

seraph

  • Level 1 Member
  • *
  • Posts: 7
Re: Oops! Page on DIR-857
« Reply #13 on: June 05, 2012, 07:48:02 AM »

@ FurryNutz:
http://www.aeroxp.org (they've since become http://www.winjade.net)

@ Beeder:
My MTU has always been 1500
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49059
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Oops! Page on DIR-857
« Reply #14 on: June 05, 2012, 07:50:54 AM »

I get the following from work when going to the aeroxp.org site:
Hostname lookup for "www.aeroxp.org" failed

I can get to the new site.

I presume the Oops page is working correctly in that it is detecting a problem since the old site is not working, the Oops page should appear. The new site should not and you should be able to access it with out problems.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!
Pages: [1] 2 3