• November 15, 2019, 09:23:50 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Bonjour connections "disappear" (RESOLVED)  (Read 46552 times)

becofatl

  • Level 1 Member
  • *
  • Posts: 3
Bonjour connections "disappear" (RESOLVED)
« on: January 23, 2012, 06:09:35 PM »

I have a D-Link DIR-825 (rev B).  I am having a problem accessing a couple of devices that are connected via Apple's Bonjour technology from Mac OSX machines.  Specifically, the two devices that broadcast via Bonjour are:

1) Netgear ReadyNAS NV+
2) HP PhotoSmart C6180 inkjet printer

When things are working right, the ReadyNAS appears in the Mac's Finder without having to connnect directly to the server and I have no problems printing to the printer.  I'm attributing this to Bonjour due to the number of items I've read elsewhere that seem to attribute this sort of issue to Bonjour and the router configuration--and it does seem to be a common denominator with the two devices above.

If I have just rebooted the DIR-825 or, in some cases, rebooted one of the two problem-devices above, then I can succesfully connect.  However, after a period of time (say 45-90 minutes), the devices lose their connection to the Mac machines (I have Windows machines and they don't have problems, presumably because Bonjour isn't in the picture).  I have Safari configured where I can see the Bonjour devices as well and suddenly they no longer appear.  I CAN connect to the ReadyNAS manually on the Mac (Finder-> Go -> Connect to Server) via smb, but that won't allow me to use the ReadyNAS as a TimeMachine device (which I believe requires AFP).

I can't be positive, but this seems to have begun when I upgraded the firmware on th DIR-825 (my wife was having problems consistently getting a WiFi connection to her iPhone, and upgrading router firmware was one of Apple's suggested troubleshooting steps).  I believe I was on version firmware 2.03NA before the upgrade.  I know I had to apply at least two different firmware releases to get to the present 2.06NA.  I never had significant problems with connectivity to the aforementioned devices prior to the firmware upgrade.  Now, I can't sustain a connection for more than a couple of hours.  Outside of that, my wireless and wired connectivity to the Internet is great--and my wife's WiFi connection on her iPhone, the impetus for the firmware upgrade, is much more consistent.

What can be done to address this problem?  I feel like I don't have something configured correctly or that the firmware made a new setting available that I don't have set correctly.  (I am attributing this to router settings because the two devices always seem to "disappear" from my Macs at the same time.)  If nothing else, is it possible to "go back" to a prior firmware and see if that helps?  

(I hope this isn't too much information.  I am not a router/IP expert.  I know just enough to be dangerous.)

Environment:

Internet Connection: DSL (AT&T, formerly BellSouth)
Modem's DHCP disabled.

Router: D-Link DIR-825 Rev B (firmware 2.06NA)
PPoE Connection to DSL modem; using Router as DHCP server
Wireless Security - WPA Personal (TKIP and AES cipher)
Other things I've tried that are a part of the present configuration:
WAN Traffic Shaping/QoS - Disabled
Firewall Settings: SPI - Disabled; UDP Endpoint Filtering - Address Restricted; TCP Endpoint Filtering - Address Restricted
Advanced Network: Enable IPv4 Multicast Streams - Enabled; Enable IPv6 Mutlicast Streams - Enabled

Computers having problem: iMac, Mac Book Pro -- both running OS X 10.7.2.  One connects wirelessly, the other connects via a LAN port on the DIR-825

Other info:
The C6180 printer and ReadyNAS NV+ are both connected via Ethernet cable to a Netgear GS105 5-port switch that is in turn plugged into a LAN port on the DIR-825.

« Last Edit: October 10, 2012, 10:28:35 AM by FurryNutz »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bonjour connections "disappear"
« Reply #1 on: January 23, 2012, 06:37:00 PM »

Netgear? You mean D-Link?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

becofatl

  • Level 1 Member
  • *
  • Posts: 3
Re: Bonjour connections "disappear"
« Reply #2 on: January 23, 2012, 06:39:56 PM »

Yes, D-Link DIR-825.  I corrected the original post.  Too many different brands of devices here.   :) 
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bonjour connections "disappear"
« Reply #3 on: January 23, 2012, 06:46:12 PM »

Can you connect the NAS and printer directly to the 825 and test?

Some things to try:
Ensure DNS IP addresses are being filled in under Setup/Internet/Manual? You can find these under Status/Device Info/Wan section.
Turn off ALL QoS (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices on the router. Setup/Networking
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall if you have this option.

Turn off Short GI, WLAN Partiton and Extra Wireless Protection if you have it. Under Advanced/Advanced Wireless.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

becofatl

  • Level 1 Member
  • *
  • Posts: 3
Re: Bonjour connections "disappear"
« Reply #4 on: January 24, 2012, 06:57:17 PM »

Before dealing with comprehensive reserved IP addresses for DHCP and re-running wires to go directly to the LAN ports, I tried adjusting the one other setting that didn't match your suggestions: The "Endpoint Independent" setting under the Advanced->Firewall options. 

When I changed the Address Restricted filtering setting to Endpoint Independent for UDP and TCP, that seems to have fixed the issue.  The printer and NAS device are now readily recognizable by my Macs.

(Some day I will try to understand, from a technical perspective, why this fixed the problem.)

Thanks for your assistance!

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bonjour connections "disappear" (RESOLVED)
« Reply #5 on: January 25, 2012, 07:33:05 AM »

Interesting that the Firewall settings were interfering. Glad you found the fix. Wouldn't think that the settings would effect Bonjour, specially on an internal LAN side.

Enjoy.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

phippster

  • Level 1 Member
  • *
  • Posts: 1
Re: Bonjour connections "disappear"
« Reply #6 on: April 11, 2012, 11:11:02 PM »

I was having this exact same problem after upgrading from the DIR-655 to the DIR-825.  Exact same settings but the DIR-825 would make the HP OfficeJet printer disappear from the bonjour connections.  Subsequently the Apple TV, iTunes Sharing and other Bonjour services would disappear as well.  Simply swapping the 625 back would solve it.  So, reading through this post, sure enough the solution was to set "Endpoint Independent" for TCP and UDP under Advanced/Firewall.  That shouldn't make any difference as bonjour is LAN and the firewall should be working with WAN packets only but it solved it for me.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bonjour connections "disappear"
« Reply #7 on: April 12, 2012, 06:59:37 AM »

Enjoy.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

utguynola

  • Level 1 Member
  • *
  • Posts: 1
Re: Bonjour connections "disappear"
« Reply #8 on: August 03, 2012, 11:21:39 AM »

I was having the same exact problems.  I have one desktop plugged into a rear ethernet port of the DIR-825 (Hardware Rev.B1, Firmware Version 2.07NA). Two aiport expresses (plugged to Bose powered speakers in separate rooms) connected via the 5GHz band.  A laptop and a HP Aiprint-enabled printer in another room via the 2.4GHz band and two Iphones.
For the longest time I couldn't get my Airports or Airprint devices to stay connected. They would work for 5 minutes and then disappear.  Likewise, I'd use my Iphone's remote app to try to control Itunes to play music to the Bose speakers and my phone could not recognize that Itunes was open.  My Iphone couldn't recognize my Airprint printer either.
SOLUTION:
Go to ADVANCED: Firewall>>Address Restricted Filtering>>select Endpoint Independet for both UDP and TCP
Note: This fixed the issue with Airprint and Airport devices disaapearing and not working properly. BUT-My Iphone's remote control app still could not find any Itunes libraries open.
SOLUTION:
Go to ADVANCED: Advanced Network>>uncheck the Enable IPv4 Multicast Streams box
Note: after the DIR-825 resets, restart any computer that was previously on to get the Bonjour service to rescan the current status of any Bonjour devices on the network (Airprint and Airports).

These settings have been stable for a week now.  My Airprint printer shows up and works properly every time I check on my Iphone.  My Airports show up in Itunes and I can stream music to those two different sets of speakers without issues (from any computer or Iphone).  My Iphone's remote control app has been working flawlessly.   

I read elsewhere that Airprint's bonjour service can be finicky if your printer gets a new IP address everytime you restart your router so I gave the HP printer its very own permanent IP address just in case.  (Setup>>Network Settings>>Hit RESERVE for the device listed under Number Of Dynamic DHCP Clients>>It's name will automatically be filled in the proper blanks under ADD DHCP RESERVATION and click SAVE.Then Click SAVE SETTINGS above before exiting).

I hope this helps many folks out there having the same issues.  I know I spent too much time researching this fix. Best Wishes.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Bonjour connections "disappear" (RESOLVED)
« Reply #9 on: August 03, 2012, 11:37:37 AM »

Awesome, thanks for the info and feedback. Will come in handy.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting