Intel PRO/Wireless 2200BG will not connect to DIR-601

(1/7) > >>

Tempest8008:
My RIM Playbook will connect to the DIR-601.
My HP Laptop with the Intel WiFi 5300 AGN will connect to it.

However the Acer Aspire 1640 with the Intel PRO/Wireless 2200BG will not.

SYMPTOMS:  The system can see the network SSID, even seems to pick up the correct encryption (AES or TKIP) and also whether I've configured it for B or G modes.  However when I attempt to connect to the network, the system prompts for the key, then pretends like it never did.  A second attempt prompts for the key, and attempts to connect, but fails, simply saying "Cannot connect."

SOFTWARE: This laptop is running Windows XP Home Edition SP3.  I've tried connecting using the Intel client PROSET software (the newest version, just downloaded) as well as the native Windows client.  THE EXACT SAME BEHAVIOUR OCCURS, leading me to believe it's not a software issue.

HARDWARE: This is a D-Link DIR-601 at Hardware Version B1 and Firmware Version 2.00NA


I have the router set to WPA-Personal, WPA2 Only, TKIP (have tried it on AES too), G only (have also tried B only).  The router has already been hard reset and I started over from scratch.  I've also ensured I have the latest drivers for the wifi adapter.

Right now I'm at a loss.

Other laptops, tablets, and even phones can connect to the router with no issue.

Seems like this is an incompatibility with this particular Intel WiFi adapter, but cannot find any official list of incompatible hardware I can use to confirm.

Would changing the software to DD-WRT help in this case, do you think? Or is this more likely to be a hardware thing?

FurryNutz:
Turn off Short GI, WLAN Partiton and Extra Wireless Protection if you have it. Under Advanced/Advanced Wireless

Try turning off security on the 601 and test to see if the Intel will connect. Then try Single mode G with TPIK only and test.

Tempest8008:
Thanks for the reply.

I have tried it with no wireless security at all, wide open, and the same behaviour occurs.
But the second I plug in a Linksys or other USB WAP adapter to the laptop, I can connect through that device with no issue.

I tried your settings under Advanced Wireless and the problem remained.

At all stages in this I was connecting to the D-Link with another laptop as well, after each change, and that other laptop connected with no issues.

I even went into the Configuration of the wireless hardware on the affected laptop and changed some of the settings to do with Power Management and Preamble...tried setting it to a specific 802.11g channel and matched it on the 601, and a few other things.  No dice.

With this particular person, I'm recommending they return their D-Link DIR-601 and I'm going to set them up with my spare Linksys WRT54G.  I've already tested the laptop on that device and it works normally with open, WEP, WPA, WPA2...

I've read a LOT of articles and blogs on the DIR-601 over the past few days, and most have been either uncomplimentary or ambivalent.  This device doesn't seem to have many fans, and at least in my case, I can see why.  I'm an isolated incident on older hardware, but 802.11a/b/g/n is a standard for a reason.  This hardware SHOULD work; it just doesn't.

FurryNutz:
Do the linksys or usb adapters connect to the 601 router?

I'm thinking there is a compatibility or user configuration issue here.

Do any other devices connect to the 601 router? If so, then maybe there is just a configuration issue on the Laptop.

This is a solid router and works well.

Uncle Dano:
I have exactly the same problem, except with the DIR-615 router. Running Windows XP on a Dell Laptop with the Intel PRO/Wireless 2200BG wireless network card. I have done everything the OP did as well. Everything! It's almost this OP was me on this machine. There is an incompatibility issue with these D-Link routers and this particular wireless network card on Windows XP. I have the identical laptop running Ubuntu Linux and it connects fine to the DIR-615. So, it is not a hardware compatibility issue it is a Windows XP driver issue for this wireless card. I have had no success with the original OEM drivers as well as the Intel updated drivers.

I have worked through D-Link Tech support on the phone 2 times now and still cannot connect this laptop to this router. Unless someone has a solution that is specific to this combination of router/wireless card on XP I will be returning my D-Link router and buying another brand, such as Linksys as this laptop connects fine to that type of router all the time.

Thank you in advance to anyone who has the solution to this problem.

Navigation

[0] Message Index

[#] Next page