• November 30, 2020, 12:40:52 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DCS-930L doesn't work with WPA encryption  (Read 6043 times)


  • Level 1 Member
  • *
  • Posts: 2
DCS-930L doesn't work with WPA encryption
« on: December 25, 2011, 03:30:45 PM »

I can't get my brand new DCS-930L cam to connect to my network by using the WPA / WPA2 encryption.
Works ok wired, with WEP or with no encryption enabled. Red led is on the front.
I've tested sw version 1.02, 1.03 and the latest 1.04b03. Same result: WPA doesn't work.
I have a Thomson TG789 Gateway/Router as provided by my ISP.
All other units in the network works perfectly fine on WPA i.e. PC, Mac, printers, mobile phones etc etc.

Any solutions or suggestions?


  • Level 1 Member
  • *
  • Posts: 4
Re: DCS-930L doesn't work with WPA encryption
« Reply #1 on: December 28, 2011, 02:15:37 PM »

Hi, Leo - not sure how much help I can be; but mine seems to work fine (at least the WPA part).  Have you tried the camera in the same room (or at least close to) the router?

My issue - talking to support right now - is that it doesn't STAY connected to my wireless network
Clay Jackson