• October 18, 2017, 12:29:14 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Wake on Lan support  (Read 13126 times)

goslow2gofast

  • Level 1 Member
  • *
  • Posts: 22
Wake on Lan support
« on: November 20, 2011, 03:07:33 PM »

In my prior DIR-655 I was able to define a Virtual Server on UDP port 9 that would reference IP address 192.168.0.255 so that if I sent a wake on lan packet to my home via it's cable modem IP address, it would hit the dlink router and broadcast it so I could wake my PC.  I don't think using the internal IP address for that PC since it is powered off.  Worked great before.

On the DIR-645 when I try to use that IP address I now get an error "the input hostid is out of the boundary".  How would I correct this and get the same broadcast approach I had before?

~gs2gf
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43354
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Wake on Lan support
« Reply #1 on: November 21, 2011, 07:15:28 AM »

Not sure of these routers support WOL, there have been some that haven't. There is a WOL sticky over on the DGL-4500 forum if you want to see if that helps any. Let us know.
Logged
Cable:100mb/3Mb>Motorola SB6183>DIR-880L>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,826L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L and a Boxee.
Go Here>Router Troubleshooting

goslow2gofast

  • Level 1 Member
  • *
  • Posts: 22
Re: Wake on Lan support
« Reply #2 on: November 27, 2011, 07:07:49 PM »

Took a look at that but it seems to indicate the same approach I was using.  I'm going to email tech support and see if they can shed any light.

~gs2gf
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43354
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Wake on Lan support
« Reply #3 on: November 27, 2011, 10:59:01 PM »

Be aware that some routers don't support WOL.
Logged
Cable:100mb/3Mb>Motorola SB6183>DIR-880L>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,826L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L and a Boxee.
Go Here>Router Troubleshooting

goslow2gofast

  • Level 1 Member
  • *
  • Posts: 22
Re: Wake on Lan support
« Reply #4 on: December 04, 2011, 06:51:36 AM »

Be aware that some routers don't support WOL.

Right, but I'd like to know if that is the case for this router or not.  It seems like a problem using the broadcast address in the server setup is the barrier, which could just be a firmware edit that needs to be adjusted.

I did contact tech support via email and they had me apply the .01 firmware update, but that didn't help.  At that point they said I'd have to get on the phone with them sometime, and since I'm at work during the day and router is at home, that hasn't worked out.

A bit disappointed in this gap for this router at this point...

~gs2gf
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43354
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Wake on Lan support
« Reply #5 on: December 05, 2011, 07:01:32 AM »

Noticed that this feature has not been supported in some of Dlink routers. I guess I would give them a call and talk to someone directly. Ask for level 2 or 3 if they have that option. Someone with some knowledge of the router and not someone who reads from a script. Did you review the WOL sticky in the DGL-4500 forum? I think there is a WOL thread in the 655 forum too.

Theres just not alot of call for this option for these home routers. These are for mostly average home users and gamers that are looking to get online and go. The tweekers like us have to find what works for us or tinker around to make it work.
Logged
Cable:100mb/3Mb>Motorola SB6183>DIR-880L>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,826L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L and a Boxee.
Go Here>Router Troubleshooting

woodbar

  • Level 1 Member
  • *
  • Posts: 6
Re: Wake on Lan support
« Reply #6 on: January 17, 2012, 05:48:29 AM »

Not sure if you sorted the WOL yet with the DIR645 - just in case I can confirm IT DOES work - I actually checked with D-Link support before purchase as it was essential for me - they confirmed "it should work"

1) Make sure the device you need to WOL has a reserved DHCP address in the "Setup/Network Settings" section.  This actually binds the devices mac address to its IP address - as the WOL packet is sent to a MAC address (The device is OFF so does not have a functioning IP address!)

2) Set up port 9 forwarding - rather obtusely this is enabled under "Advanced/Virtual Server" and NOT in "Port Forwarding"!

3) Click "Application" - choose WOL / set "Protocol" to UDP  / enter the IP address you reserved in (1) /  enter 9 for public & private port.

This does mean that the WOL is device specific and is not "Broadcast" across your internal network - not sure if you could set up another rule using a different port if you have more than one device requiring WOL?

Just for completeness - this wakes my NSA310 everytime from my Android Tablet using a suitable WOL packet generator with the following settings:

MAC - of the device you defined in (1)
I.P. - mine is via dyndns - or use actual I.P. if your ISP gives you a fixed address
Port - 9
Subnet - 255.255.255.255
Broadcast - enabled

.... and just to add the "belt and braces" approach I send this 3 times at 1 sec interval.

Hope that's useful.

Now all I have to do is find out why the Wifi, controlled using the "Schedule" function, quite often either does not switch back on or sits there, broadcasting its' SSID, but refuses all connections!
Logged

goslow2gofast

  • Level 1 Member
  • *
  • Posts: 22
Re: Wake on Lan support
« Reply #7 on: February 01, 2012, 07:37:11 PM »

I think that will only work for as long as the computer that you are waking still responds on that IP address.  I don't think that the router will send the WOL packet out to the mac address involved, or as a broadcast to all network devices the way you have it set up.  But I will do a little testing next week...

~gs2gf
Logged

goslow2gofast

  • Level 1 Member
  • *
  • Posts: 22
Re: Wake on Lan support
« Reply #8 on: February 23, 2012, 11:14:04 AM »

Not sure of these routers support WOL, there have been some that haven't. There is a WOL sticky over on the DGL-4500 forum if you want to see if that helps any. Let us know.

Well, for what it's worth, Wake-On-Lan is a choice in the drop down list on the Virtual Server Setup page, so given that I would feel like it should be supported, right?

~gs2gf
Logged

goslow2gofast

  • Level 1 Member
  • *
  • Posts: 22
Re: Wake on Lan support
« Reply #9 on: February 23, 2012, 11:17:25 AM »

Not sure if you sorted the WOL yet with the DIR645 - just in case I can confirm IT DOES work - I actually checked with D-Link support before purchase as it was essential for me - they confirmed "it should work"

1) Make sure the device you need to WOL has a reserved DHCP address in the "Setup/Network Settings" section.  This actually binds the devices mac address to its IP address - as the WOL packet is sent to a MAC address (The device is OFF so does not have a functioning IP address!)

2) Set up port 9 forwarding - rather obtusely this is enabled under "Advanced/Virtual Server" and NOT in "Port Forwarding"!

3) Click "Application" - choose WOL / set "Protocol" to UDP  / enter the IP address you reserved in (1) /  enter 9 for public & private port.

This does mean that the WOL is device specific and is not "Broadcast" across your internal network - not sure if you could set up another rule using a different port if you have more than one device requiring WOL?

Just for completeness - this wakes my NSA310 everytime from my Android Tablet using a suitable WOL packet generator with the following settings:

MAC - of the device you defined in (1)
I.P. - mine is via dyndns - or use actual I.P. if your ISP gives you a fixed address
Port - 9
Subnet - 255.255.255.255
Broadcast - enabled

.... and just to add the "belt and braces" approach I send this 3 times at 1 sec interval.

Hope that's useful.

Now all I have to do is find out why the Wifi, controlled using the "Schedule" function, quite often either does not switch back on or sits there, broadcasting its' SSID, but refuses all connections!

Are you really using 255.255.255.255 as the subnet mask, that isn't allowed on my DIR-645.

~gs2gf
Logged