D-Link Xtreme N (Platinum Products) > DIR-655

DIR-655 Port Forwarding Doesn't Work From LAN PC

(1/5) > >>

Drackir:
Edit I've found a work-around. It's on page 2: http://forums.dlink.com/index.php?topic=38542.msg128327#msg128327. Basically, use Virtual Server instead of Port Forwarding.

I'm having this really weird issue with my DIR-655 revB. I have some port forwarding rules set up and externally they work fine. However, if I try connecting to my IP address using those same ports from a computer within my LAN, it won't connect.

Externally, I can ping my WAN address and connect through forwarded ports. No problems.
Internally, pinging my WAN address apparently works (just now is the first time that's worked for me), however I can't access any of my computers using the WAN IP and port forwarded ports. I can access them by going directly to their hostnames or LAN IPs.

Things I've tried:
-Disabling/enabling firewalls on all computers involved
-Disabling/enabling QoS engine
-Disabling/enabling DNS relay
-Disabling/enabling Advanced DNS
-Adding custom nameservers from Google and Comodo
-Restarting computers
-Clearing DNS cache (I use a dynamic DNS name which works externally but not internally. This gets the correct IP internally and connecting directly to the IP doesn't work either.)
-Modifying the NAT Endpoint Filtering settings

I have an external DSL modem connected to the router using PPPoE if it matters.

The weird part is that it works externally but I've modified all of the values I can think of in the config with no luck. I upgraded to the DIR-655 from a DIR-615 which had all these settings in it and worked fine (until it started acting up which is why I replaced it).

Does anyone have any idea what I can do or what might cause this? I'm quite a tech savvy individual and it's very frustrating when nothing seems to work.

Thanks for your time.

Edit: Also, after looking at it, the router is set to ignore ping requests despite the fact that it does, indeed, seem to reply.

FurryNutz:
Have you tried connecting to a shared folder using the following method?
\\hostpcname\nameofsharedfolder

\\mypc\movies
or

\\192.168.1.1\movies
For internal LAN connections, the above method is only needed if all devices provided are using the same work group name and that you have shared out a folder(s) to be able to access.

I also recommend setting up DHCP Reserved IP addresses for each devices on the router as well so they have and IP address that doesn't change and is easy to manage and troubleshoot.

Drackir:
Thanks for your reply.

Yes, my network shares work fine.

The issue is, for example, I have remote desktop set up on one of my PCs. The router forwards incoming connections on the RDP port to that PC. This works fine when I'm using the remote desktop from an external source, say, my office via my WAN IP. However, if I try to connect to the same IP and port from a computer within my network (not the one with remote desktop), the connection cannot be established. It hangs for a while which makes me wonder if something is getting sent but not receiving a response.

I run some servers/programs on different computers in my LAN with forwarded ports and all of them act the same way so I don't think it's related to the PCs or the programs.

I have all my devices set up with reserved IPs via DHCP in the router.

As I said, this all worked on my old modem until it died. So I think it must be in the firmware, but I don't know how to track down the issue.

FurryNutz:
How are you formatting the RDP  reqeust for the LAN pc? I presume it would be just the IP address or host name of the PC your trying to connect to.
 

Drackir:
It works if I use the hostname, but not WAN IP from a LAN computer. So it's getting lost somewhere going out into the internet and coming back (or maybe not even making it that far).

It seems like when I try to access the WAN IP from within the network, the Port Forwarding settings are ignored or the connection isn't going through.

I'm not sure if there's a way I can test it because external tools (websites, etc.) CAN get through on those ports, it's only stuff in my LAN that doesn't work.

Navigation

[0] Message Index

[#] Next page

Go to full version