The Graveyard - Products No Longer Supported > DSM-750

Bricked DSM-750

(1/4) > >>


My 750 gets stuck on the initial splash screen, forever. I tried holding the reset button for 10, 15, 30 and even 60 seconds to no avail. I unplugged it for a while and tried again, same thing.

I also found out after countless attempts that from an off state, pressing the reset button (a short touch, not holding) and having a USB stick plugged into the USB port puts the device in "safe mode", however when I click "next" to proceed with the upgrade it says the firmware is invalid (I tried with various versions downloaded from here:

I basically have the same problem described by rob_t in this post:
Except that my reset button seems to be still functional. Nonetheless I followed his advice and opened the thing up and the capacitor he refers to does indeed seem to be a bit bulged (I'm no electronics experts so I can't really tell what's too much).

Any tricks or advice on this or should I go nasty and do as rob_t?


PS: Hate to say it but you guys need to improve your phone support; it is always a disappointing and frustrating experience.

I never tried anything with a memory stick plugged in, so I can't say if you're getting the same behavior there as I did, but apart from that it sounds related. The top of the capacitor should be completely flat, any bulging is a sign of something going wrong inside the capacitor, but sometimes the capacitor will still work well enough (at least at first).

BTW I've been fooling around with electronics and soldering irons for about 80% of my life. I don't encourage anyone to start swapping out components unless they have the experience (and tools) to be able to do it without damaging the circuit board.


Hey Rob,

Thanks for replying. I ordered the capacitor and a new soldering iron and should be getting it this week. I haven't touched one in a while, but it won't be my first time using one.
I am far from an electronics expert, but as long as I have a good idea of what I'm supposed to do I think I'll be OK. I'll let you know how it goes.

Do you think that could be related to power a outage/surge? Or just cheap components that won't last forever?

Thanks once again for your help.

There is power regulation ahead of this voltage regulation circuit (just like the CPU Vcore generator in a PC that draws it's power from the regulated 12V supply). I'd be surprised if the problem was caused by a power surge, but it's possible.

Good luck with the replacement. Lots of patience helps since getting components off a thru hole plated board like this is never trivial (although quite doable with the right tools).

I managed to replace the capacitor but still no luck, gets stuck at the splash screen.

Well, lesson learned I suppose. This is strike 3 for me with D-Link, they've made me waste over $500 with different devices combined.

Hey Rob, since you've also taken a peek into this thing, any idea what/where else I can reuse its components for?

I wish these guys would release the firmware's source code since they are no longer supporting it.


[0] Message Index

[#] Next page

Go to full version