Standard to Raid 1 Configuration

(1/3) > >>

cachaca:
Hi,

1. I am using DNS-320 Firmware 2.0. I started off installing just 1 x 2TB Samsung HD204UI on the LEFT BAY. All my data has been transferred into this HDD (about 1TB filled up with 1TB space left). Auto-rebuild DISABLED.

2. Decided that I should install RAID1 mirroring and bought an identical 1 x 2TB Samsung HD204UI to be placed on the RIGHT BAY.

3. Once I plug it in and power up the NAS, I chose the option to FORMAT the new 1x2TB on the RIGHT BAY leaving the data on the LEFT BAY untouched. There was an option to make the new HDD to be RAID1 however the checkbox is IMPOSSIBLE to be selected. So, i just proceeded to FORMAT. The initialisation was fine but the status bar stucked at 0% when FORMATTING. As per other discussions I manage to successfully format the new HDD if it is placed on the RIGHT BAY or LEFT BAY on a STANDALONE BASIS. (e.g. no 2nd HDD). However, whenever I place the DATA HDD in the LEFT BAY and the new HDD on the RIGHT BAY, the formatting will just hang at 0%.

4. How can I install the 2nd HDD and setup RAID1 without losing my data on the original HDD place on the LEFT BAY?

5. I googled and check DNS-320 for procedure to migrate from standard to RAID1 but the weblink provided is just a broken link. Refer to http://www.dlink.com.sg/site_support/DNS-320/DNS-320_how_to_perform_HD_migration.pdf,

PLEASE HELP.

Thanks,

cachaca:
Additional information:

1. My DATA HDD on the LEFT BAY is configured as "Current Raid Type: VOLUME_1: STANDARD"
2. I cannot change the "SET RAID TYPE AND RE-FORMAT" as I will lose my DATA on the HDD.
3. When I place the new HDD in the RIGHT BAY, I can't do "FORMAT THE NEW DRIVE AS STANDARD TYPE" and "SELECT THE RECONFIGURE TO RAID1" CHECKBOX. Somehow the checkbox is unselectable.

Any IDEA?

The paragraph reads below but can't be done...

Format the new drive as Standard type
This window will appear when a new HDD is added to the ShareCenter when there is already a single Standard formatted HDD installed. You can select the Reconfigure to Raid 1 checkbox if you want to setup the two disks in a RAID 1 format without losing the data of the already installed HDD. If you do not check the Reconfigure to RAID 1 box then you can format the new HDD as a Standard volume and the data of the first HDD is preserved in Standard volume format.

JavaLawyer:
Here's a thread addressing the same issue for the DNS-323:
http://forums.dlink.com/index.php?topic=9148.0

D-Link Multimedia:
I would highly suggest backing up your data if possible. Try removing any partitions that were created on the new 2TB drive using your PC and re-insert the drive back into the NAS and reboot. It should give you the option to convert to Raid 1 in the format process unless for some reason the detected sizes are not correct (like the new one is smaller than the old one) however if they are identical drives they should be detected with identical space so I don't see why that would be the cause.

cachaca:
Hi DLINK,

Thank you for your prompt response. Unfortunately I have also tried your suggestion by clearing up any partitions in the NEW HDD. Yes, I do get the option to select the RECONFIGURE TO RAID 1. However, it is IMPOSSIBLE to click on it. It wasn't gray out but just not selectable.

Since yesterday, I have done further troubleshooting but still no luck. Below is a more detail description.


1.   Problem: Unable to migrate from a Standard Volume to a RAID1 Volume. Below is the description:-
2.   Model DNS-320, PN: INS320B….A1E, SN: PVRR1B1000177. HW Version A1. FW Version 1.00. MACID: 3408049CC665.
3.   The firmware has been upgraded to 2.0. Screenshots as below for your reference.
4.   The background as follows:-
a.   We initially setup 1 x 2TB Samsung HD204UI based on standard volume. (No Raid Configured).
b.   We migrated all the data into the 1 x 2TB HDD. It is presently around 1TB of data in the HDD
c.   We decided to setup RAID1 mirroring and purchased a new 1 x 2TB Samsung HD204UI which is identical to the existing one.
d.   We placed the new 1 x 2TB HDD in the NAS and selected “Format the New Drive as Standard Type” but was unable to select the “RECONFIGURE TO RAID1”. Refer to screenshot below. You can see that we are NOT able to click on it even though we tried. Therefore we just proceed by clicking next.
e.   However, after initialisation formatting the new HDD as VOLUME_2 will just stuck permanently at 0% even though we waited for HOURS. We have to manually shutdown the NAS in order to resolve this stuck problem.
f.   After troubleshooting we confirm that each time if there is a VOLUME_1 HDD inside the NAS (regardless whether it is in the LEFT BAY or RIGHT BAY), it is always not possible to format a new HDD as VOLUME_2 and it will just stuck permanently at 0%. However, if we place the NEW HDD on a STANDALONE basis regardless it is on the LEFT or RIGHT BAY. The initialisation and formatting of the NEW HDD will be smooth without any problems and successful.

So, I believe, it is not possible to perform a new HDD formatting of VOLUME_2 with another existing VOLUME_1 HDD inside the BAY. If you remove HDD and it is being formatted as VOLUME_1 HDD, then if you then place it in, then it is fine and will be recognised as two different STANDARD VOLUMES. But this is not something I am looking for because I need to set up as RAID1.

Appreciate your help and thanks in advance







Navigation

[0] Message Index

[#] Next page