• July 09, 2020, 08:34:03 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Dlink dsl-2640b port forwarding problem on port 80 - Private webserver  (Read 4667 times)

lilloraffa

  • Level 1 Member
  • *
  • Posts: 1

dear all,

first of all, I apologyze if there is already a solved post like this: I've tried to search before writing a post, but found nothing...
I'm trying to set up a webserver form my pc, which I need to connect from outside through my public ip. After configuring apache and php, I configured my router in order to forward every external request on port 80, to the port 80 of the local ip of the machine where the webserver is running. (portfowarded port 80 to 192.168.1.4). My model/router is a Dlink dsl-2640b. I'm using ubuntu 10.10 server.
My problem is that even if I told the router to use the 192.168.1.4, it forward the request to my public ip to the admin page of the router itself (192.168.1.1).
Does anyone have an idea on what's is going on?
Thanks a lot.
Logged

Ricardo

  • Level 1 Member
  • *
  • Posts: 4

I have the same problem, and Im waiting d-link give us a answer. But I have windows and disabled firewall. I did everything that is possible. The 2640b do not forward any request to the socket we want. We need this solution to still using d-link products.
Logged