The Graveyard - Products No Longer Supported > DIR-655

problem with firmware newer than 1.02


I bought DIR-655 a couple of months ago.  So far, I haven't been able to get the newer firmwares (>1.02) to work.  My wireless PCs would disconnect after a while, sometimes after less than a minutes, sometimes after half an hour.  Whenever this happens, the PCs wouldn't connect unless I reboot the router.  Also the router would stop logging.  It appears that the router software has crashed.  However, the wired PC always stays connected.

Obviously the newer firmware works for lots of people.  I have no idea what's wrong with my setup.  I have several desktops in the house.  One with HP wireless card and the rest with D-Link cards.  One is D-Link N card.  I have tried many different settings for the router and tried hard rest many times.

Firmware 1.02 hasn't had such a problem.

With firmware 1.02, wireless N or mixed with N mode doesn't work.  None of my cards could connect.  Not even the D-Link N card.  They could connect with N mode under firmware 1.03 but  the connections wouldn't last.

Read my post on


[0] Message Index

Go to full version