• September 19, 2019, 10:50:55 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3 4

Author Topic: DNS 323 Error: "The hard drives have been installed incorrectly."  (Read 31426 times)

desmoquattro

  • Guest

So I get my new DNS 323, new Seagate 500GB hard drives, and I'm stoked. I formatted it using RAID 0, and the drive appears just fine. I can move data to & from it, etc. But every time I try to log into the web admin console with the default username & password, I get the following error:

HARD DRIVE CONFIGURATION:
The hard drives have been installed incorrectly. Please power off and swap hard drive locations.


Screen Shot:


I tried powering down and swapping the hard drives, but nothing changed: I can still access my drive, but get the same error when I log in to the admin console. But I can log in to the Downloads section of the web admin utility.

I filed a support ticket over the web on Wednesday, and DLink told me to call in to resolve the problem. So I called today, was handed off twice, and was ultimately transferred to a department that was closed for the holiday...after wasting 45 minutes of my day on the phone.  >:(

Has anyone here experienced this error? I found one reference to it in the forums, but it was never resolved. I'm running firmware 1.04, and I'd gladly try upgrading the firmware to resolve this, but I don't see a way to do that without getting into the admin utility.

Thanks!
Logged

fordem

  • Level 10 Member
  • *****
  • Posts: 2168
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #1 on: November 29, 2008, 07:08:40 AM »

I would back up the data, pull one of the drives and format the other as a standard volume - that has gotten rid of the error for me in the past.

I would also not use RAID0 on the DNS-323 - it offers no performance advantage and therefore is an unnecessary risk.
Logged
RAID1 is for disk redundancy - NOT data backup - don't confuse the two.

desmoquattro

  • Guest
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #2 on: November 29, 2008, 09:56:57 AM »

I would back up the data, pull one of the drives and format the other as a standard volume - that has gotten rid of the error for me in the past.

I would also not use RAID0 on the DNS-323 - it offers no performance advantage and therefore is an unnecessary risk.

Thanks, fordem. Normally, I'd use the admin console to format the drive. Can you point me toward another way to format it without using the console?

Thanks!
Logged

fordem

  • Level 10 Member
  • *****
  • Posts: 2168
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #3 on: November 29, 2008, 01:44:55 PM »

I'm not aware of any other way to format the drive
Logged
RAID1 is for disk redundancy - NOT data backup - don't confuse the two.

desmoquattro

  • Guest
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #4 on: November 29, 2008, 03:17:37 PM »

I'm not aware of any other way to format the drive

Hmm....maybe if I remove both drives, put another one in, format it, then put the originals back in, then format them, it'll work. That's time-consuming, though.
Logged

coxwain

  • Level 3 Member
  • ***
  • Posts: 145
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #5 on: March 14, 2009, 11:42:14 PM »

I have the same problem on a 323 that has been working for a month

Reformating is not an option
I just went to set back to default so that the drive structure would refresh and now I get this error message.

I was running the 2x1.5tb drives in JBOD format with 800gb populated

I dont want to format these drives
easysearch cant see the drive either but I can logon to the BT part of the web browser
« Last Edit: March 14, 2009, 11:44:54 PM by coxwain »
Logged
DNS-323  2x1.5TB Seagate Drives Separate Volumes
Volume1
Volume2
Playstation 3 80gb
Various computers and hardware, Win xp, Win 7,
1.07 firmware

coxwain

  • Level 3 Member
  • ***
  • Posts: 145
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #6 on: March 15, 2009, 12:07:58 AM »

my file explorer can see the drive, and easysearch can see it now but it wont allow me to access the configuration menu or add the bt

this is absolutly crazy,  there should not be these kinds of problems on this device!
Logged
DNS-323  2x1.5TB Seagate Drives Separate Volumes
Volume1
Volume2
Playstation 3 80gb
Various computers and hardware, Win xp, Win 7,
1.07 firmware

fordem

  • Level 10 Member
  • *****
  • Posts: 2168
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #7 on: March 15, 2009, 06:12:41 AM »

I just responded to your other post - which by the way says 800 megs of data, not gigs.

Here's what - if you have access to that data, and you don't have it backed up - do that NOW - I don't care how much data it is, you need to face the fact that it needs to be backed up - this is a case of back it up or risk losing it all, or, face major grief trying to recover it.

Once you have a backup - reformat - and a reformat is ALWAYS an option - it may not be convenient, it may not be what you want to do, but, given the disk configuration you are using, it's a very viable option and one that you should seriously consider.

One of the moderators was a little less than happy when, on a previous occassion, I suggested that when a disk fails in a JBOD configuration you could lose all the data, even the data on the remaining disk - so - you won't lose the data, you will however lose access to it, and regaining access will be very challenging.

Unless you expect to have a dataset exceeding the capacity of a single disk (1.5TB) - and if you do, then you really should not be using a consumer grade device - there is no other advantage to a JBOD configuration, and in my opinion it is just not worth the risk of losing access to the data.
Logged
RAID1 is for disk redundancy - NOT data backup - don't confuse the two.

coxwain

  • Level 3 Member
  • ***
  • Posts: 145
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #8 on: March 15, 2009, 06:37:52 AM »

It's 800gb
Reformat should not be a solution
They need to get the firmware or give better disk management tools

I am not hAppy with dlink know

I did. Notice that. File explored got acces to it so I am hopping the drive reindexed itself last night
Logged
DNS-323  2x1.5TB Seagate Drives Separate Volumes
Volume1
Volume2
Playstation 3 80gb
Various computers and hardware, Win xp, Win 7,
1.07 firmware

Zardoz66

  • Level 2 Member
  • **
  • Posts: 49
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #9 on: March 15, 2009, 06:53:37 AM »

hehe, if a format "fixes" your problem then IT is a solution. it might be one you like, but still a solution. not all solutions are going to be popular. ever.
Logged
Zardoz66

DGL-4300 v1.9 | DAP-1522 v1.20 | DGS-2208 | DPR-1260 v1.24 | DNS-323 v1.6
1Gb JF=9k single drive mode
1 Seagate ST3300831AS 3NF1E956 300 G 
2 Seagate ST3300831AS 3NF1E03G 300 G

coxwain

  • Level 3 Member
  • ***
  • Posts: 145
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #10 on: March 15, 2009, 07:41:21 AM »

just checked, it didnt reindex the drive in the last 5 hours

Its funny, the web browser lets me logon to the download side, but wont let me into the BT folder

But it does look like the bt is still working as it completed one of the pending downloads I had

I wonder if there is any way to remove the bt stuff and if that will give me access back to the setting menu

the drive seems to work fine


there needs to be better disk management softward
Logged
DNS-323  2x1.5TB Seagate Drives Separate Volumes
Volume1
Volume2
Playstation 3 80gb
Various computers and hardware, Win xp, Win 7,
1.07 firmware

coxwain

  • Level 3 Member
  • ***
  • Posts: 145
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #11 on: March 16, 2009, 09:30:25 AM »

Does it ever help to reflash the 1.06 firmware?  Could this fix things?

Also, I have some directories that I cannot delet on my DNS 323 drive tree

How do I reset my directory structure?
Logged
DNS-323  2x1.5TB Seagate Drives Separate Volumes
Volume1
Volume2
Playstation 3 80gb
Various computers and hardware, Win xp, Win 7,
1.07 firmware

fordem

  • Level 10 Member
  • *****
  • Posts: 2168
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #12 on: March 16, 2009, 09:51:18 AM »

Does it make a difference what we say?

A reflash might fix the "the hard drives have been installed incorrectly" message especially if you do it with the drives out.  But then again - it might not, and with the drives in a JBOD configuration, removing the drives could cause you to lose access to the data.

What I doubt it will fix is the directory structure problems - my guess is only a reformat will get rid of that - but that's not what you want to hear.
Logged
RAID1 is for disk redundancy - NOT data backup - don't confuse the two.

coxwain

  • Level 3 Member
  • ***
  • Posts: 145
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #13 on: March 16, 2009, 10:38:49 AM »

Thanks for that

I am remembering last time i reset my drive  I actually took the drives out before I pressed the reset button and set the settings to default.  This time I left the drives in when I did the reset button.

I probably should have pulled the drives 1st.

Its funny I have full access to these drives from file explorer,  its just my PS3 is not getting an updated directory structure from the drive hence cant see the files through the media server options.

Maybee that twonky thing is the way to go, but I bought the 323 b/c it could do it all

I think resetting the directory structure could fix it but dont know how I would be able to do that  and havent heard from Dlink at all

thanks
Logged
DNS-323  2x1.5TB Seagate Drives Separate Volumes
Volume1
Volume2
Playstation 3 80gb
Various computers and hardware, Win xp, Win 7,
1.07 firmware

coxwain

  • Level 3 Member
  • ***
  • Posts: 145
Re: DNS 323 Error: "The hard drives have been installed incorrectly."
« Reply #14 on: March 16, 2009, 06:15:44 PM »

Well you wont beleive this, i got access back of my web interface for 323

this is what I did

remove both drives
then press the reset button a bunch of times while removing the power and putting power back (i actually dont know how to use the reset button)

then I reflashed the 1.06 firmware with out the drives in
i loaded my configuration file with all my settings that I saved previously

i shut down the 323 and put the drives back in

then started it back up and went to access the web interfact and it works

im just doing a UPNP media scan now and will keep you posted if it all works as I would like

it seems my reflashing fixed it as that is the only thing different that I did this time.
Logged
DNS-323  2x1.5TB Seagate Drives Separate Volumes
Volume1
Volume2
Playstation 3 80gb
Various computers and hardware, Win xp, Win 7,
1.07 firmware
Pages: [1] 2 3 4