• May 19, 2024, 10:58:46 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Port Forwarding on DIR-825 2.01EU not working  (Read 7638 times)

dts439

  • Level 1 Member
  • *
  • Posts: 2
Port Forwarding on DIR-825 2.01EU not working
« on: January 06, 2011, 03:20:47 AM »

Hi All,

Have just bought a DIR-825/B1 which came with the 2.01EU firmware.  This was replacing an old Netgear FVS318 firewall router (and a separet access point) as it was struggling with 20Mb download speeds and kept dropping VPN connections.

Setup seemed fine and wireless worked first time.

I had a number of devices behind the FVS318 set up with port forwarding so I diligently wrote all the settings down and mapped these into the Port Forwarding section of the DIR-825.  However when I tried to connect to the ports they never worked  :(.  Even a simple single port forwarding (for RDP) did not connect. No message was logged on the device.  I chose Port Forwarding rather than Virtual Server as it allowed me to put multiple port numbers on each device, and hence have one entry per machine.

Tried a manual telnet to a forwarded port and it just hung.  Telneting to a non-forwarded port was dropped straight away though no  message in the log).  Note these are tests from inside the network using the external DNS name.

After some research I gave in and reconfigured it using multiple Virtual Server entries and this works fine ;D.

So any ideas why Port Forwarding does not work?   I also tried adding an Allow All Inbound Filter to see if this was required but it made no difference.  I removed it when I set up the Virtual Server.
Logged

Cees

  • Level 1 Member
  • *
  • Posts: 17
Re: Port Forwarding on DIR-825 2.01EU not working
« Reply #1 on: February 06, 2011, 02:54:40 AM »

Probably you tested portforwarding from a computer inside your LAN.
Portforwarding only works from WAN to LAN, it works fine but you need to test it from another external PC. 

When you use 'virtual server' it works also from inside the LAN, as the DIR825 operates like a kind of proxy.  Portforwarding has the advantage that you can forward many ports to the same local ip-adress in just one configuration line.  Virtual Server needs one entry per port.

Also you can not use the same port for port-forwarding and virtual-server.
« Last Edit: February 06, 2011, 03:52:55 AM by Cees »
Logged

dts439

  • Level 1 Member
  • *
  • Posts: 2
Re: Port Forwarding on DIR-825 2.01EU not working
« Reply #2 on: February 06, 2011, 03:19:17 AM »

Thanks,

This would make sense from what I observed.

However this differs from the behaviour of my old FVS318 and begs the question of how you test this if you have not got an external connection available at the same site.

Dave
Logged