• November 13, 2019, 07:05:05 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DSM-520 Audio out of sync playing xvid - I found a solution  (Read 5229 times)

daveman1000

  • Level 1 Member
  • *
  • Posts: 2

Hi there,

Ihave had an annoying problem with playback of xvid (avi) files that the audio was slighlty out of sync (from .5 sec to 3 secs).

after a great deal of searching I finally found a solution (Dlink tech support was entirely useless and 4 days later I am still waiting for the promised return phone call).

There is a program called MPEG4Modifier (www.moitah.net).  It seems by adding the following into the user data section and saving the file the sync problem is resolved.

click on the + tag and enter:  DivX999b000p.
then save the file

I have tried 4 different files and the sync prblem has resolved, even when fast forwarding the file

good luck to all.  Let me know if this works for you

dave
Logged

kolinb

  • Level 1 Member
  • *
  • Posts: 23
Re: DSM-520 Audio out of sync playing xvid - I found a solution
« Reply #1 on: June 10, 2008, 03:49:49 PM »

Dude, you rock!  It works perfectly on a couple files of mine that had this problem.  Now if we can get DLink to figure out what that actually does and just do it automatically instead of us pre-processing the files.

Thx for the post,

Kolinb
Logged

stevedahl

  • Guest
Re: DSM-520 Audio out of sync playing xvid - I found a solution
« Reply #2 on: June 15, 2008, 08:04:20 PM »

Hi;

I've been struggling with the same synch problems.
I stumbled across a wonderful solution, an outfit called Tversity has a media server that is free fast and works. It has all kinds of nice bells and whistles and support for more media formats that it converts on the fly as it streams it to the DSM-520. The Tversity software also allows you to setup your own internet links which I haven't played with yet. So far I have  5 terabytes of video, audio and photos on some NAS drives there are streaming beautifully to my DSM-520.
Here is the link to their website http://tversity.com/home

Logged

kolinb

  • Level 1 Member
  • *
  • Posts: 23
Re: DSM-520 Audio out of sync playing xvid - I found a solution
« Reply #3 on: June 17, 2008, 06:04:41 AM »

Stevedalh,

Agreed, TVersity is really good however I find it takes a beafy machine if you are using the transcoding feature to convert videos into DSM-520 compatible format (especially for HD content) .  Plus you are adding an extra decoding / encoding step which will introduce artifacts. 

I will go to TVersity once I upgrade my file server, but for the time being I am trying to get the DSM-520 to play as much as possible in the files native format.  If the sync problem is fixed as simply as adding something to the avi header, then I am all for that.

Now we just need to get H.264 and MKV support...

Logged

mycomputers.ca

  • Level 2 Member
  • **
  • Posts: 36
    • MY Computers Corp
Re: DSM-520 Audio out of sync playing xvid - I found a solution
« Reply #4 on: July 12, 2008, 06:29:01 PM »

I haven't ran into the out out sync issue with audio recently so I can't really try it out yet but if i do i'll for sure look at trying this

thanks dude.
Logged