• December 16, 2019, 12:19:52 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DI-524 - Nothing happens when clicking "Apply"  (Read 9193 times)

mountainpz

  • Level 1 Member
  • *
  • Posts: 2
DI-524 - Nothing happens when clicking "Apply"
« on: November 01, 2010, 06:33:45 PM »

Hi all.

Just moved and now trying to set up wireless network at the new place. However when I go to http://192.168.0.1/h_wireless.html to change the SSID and enable WPA-PSK and then click "Apply", nothing happens.

I should say I am on a Mac desktop trying to set this up, and I can see the network on my laptop. I just can't secure it because the d-link menu won't "apply".

Can anyone help me out??

Thanks!!
« Last Edit: November 02, 2010, 08:59:39 PM by mountainpz »
Logged

mountainpz

  • Level 1 Member
  • *
  • Posts: 2
Re: DI-524 - Nothing happens when clicking "Apply"
« Reply #1 on: November 04, 2010, 03:12:12 PM »

I'd love some help with this in order to make my network secure. Doesn't look like D-link will be helping out much. I tried clicking "Apply" in explorer but no luck there either.

Thanks!
Logged

servel333

  • Level 1 Member
  • *
  • Posts: 2
Re: DI-524 - Nothing happens when clicking "Apply"
« Reply #2 on: November 25, 2010, 08:59:53 AM »

I am having the same problem and trying to fix it.  I updated my firmware, tried running the setup wizard, that doesn't offer to turn on WPA, only WEP.  I'm wondering if this router doesn't support WPA and it's a mistake that it shows that option in the drop down menu...


Current Firmware Version: 1.21
Firmware Date: Thu, 22 Sep 2005

I upgraded to

Current Firmware Version: 1.23
Firmware Date: Mon, 24 Jul 2006
Logged

servel333

  • Level 1 Member
  • *
  • Posts: 2
Re: DI-524 - Nothing happens when clicking "Apply"
« Reply #3 on: November 25, 2010, 09:10:53 AM »

Ok, it looks like the issue is Firefox, and other non-IE browsers.  I opened Internet Explorer, made the change and it worked.
Logged

waqasraja

  • Level 1 Member
  • *
  • Posts: 1
Re: DI-524 - Nothing happens when clicking "Apply"
« Reply #4 on: March 19, 2019, 04:31:54 PM »

No new browser will allow this to work so you will have to use either IE8 or IE9 for this setting to work.

My win10 had IE11 which did not do the trick so in the settings, I added my routers ip address i.e -> 192.168.0.1 in compatibility view settings and it worked.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47994
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DI-524 - Nothing happens when clicking "Apply"
« Reply #5 on: March 19, 2019, 05:52:52 PM »


This model is past EOL. Any users having this router should get into a newer model router to avoid security issues w older routers.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting