• January 20, 2021, 09:41:02 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Crontab with DNS-343 + fun_plug  (Read 4504 times)

Prowler

  • Level 1 Member
  • *
  • Posts: 2
Crontab with DNS-343 + fun_plug
« on: September 07, 2010, 08:14:22 AM »

I am having an issue, that I can't seem to get around.
 
I have 2  DNS-343 that I would like to have rysnc'd.   The primary device (NASPrimary) is running stock firmware 1.03.   The second (NASBackup) is running Firmware 1.03, and is using fun_plug .05.    The fun_plug is running I have been able to telnet no issues.

I have created an editcron.sh file for the /ffp/start  (and have copied and paste the script from the web)
I have placed my rsync script (NASbackup.sh) in /ffp/tmp   

When I run the editcron.sh it executes everything fine.  crontab -l lists my entry correctly, and triggers at the time required.

The Problem:
When I reboot the backup device (NASBackup), if I log in as soon as the IP address is displayed on the device  crontab -l shows my entry,  a few moments later (approx 1 minute)  crontab -l is back to the stock setup.    Is there anything I am missing, or what is overriding my crontab list after boot??

Thanks,
Wayne
Logged

Prowler

  • Level 1 Member
  • *
  • Posts: 2
Re: Crontab with DNS-343 + fun_plug
« Reply #1 on: September 09, 2010, 12:34:22 PM »

Update:

For those you may find it useful.

I updated the firmware to 1.04 Beta, and the crontab changes kept.    Tested with several reboots, and shutdowns.   The rsync worked as scheduled.

I did not have to re-install fun_plug
Logged