• February 24, 2020, 08:35:55 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Can't connect to some sites when using DIR-615  (Read 3170 times)

IrqReq

  • Level 1 Member
  • *
  • Posts: 3
Can't connect to some sites when using DIR-615
« on: September 05, 2010, 01:53:10 PM »

Hi,
I am going crazy...
I can't access some sites when connected to the internet through the router. i.e. www.cypress.com or ti.com
When I disconnect my desktop from the router and plug directly in to the cable modem and reboot everything, I can connect to any website and the problem goes away.
I upgraded to firmware 3.12 months ago and my router hardware version is C1.
I have one computer hard wired to the router running win 7 and 2 laptops running xp through wireless.
The problem is definitely the router.
I reset the router (via the reset pin in the back) and the problem goes away for a 10-15 minutes and then back to square one!
When I connect any of the computers directly to the cable modem, no problem. So it's not the windows version, anti virus or anything else. Tried with firefox, google chrome, and IE8. Same problem.
The problem is with the router but I don't know what can cause this.
Googled this and searched for the error message "Internet Explorer cannot display the webpage" and found others that are having the same problem with the DIR-615 but no solutions were put forward.
Can anyone help me before I end up in the nut house?
Thanks in advance...
 
Logged

!!!!clarkkent

  • Level 3 Member
  • ***
  • Posts: 104
Re: Can't connect to some sites when using DIR-615
« Reply #1 on: September 05, 2010, 09:54:54 PM »

Try reducing the MTU size
Logged
"A mighty sword is useless in the hands of a coward!"

IrqReq

  • Level 1 Member
  • *
  • Posts: 3
Re: Can't connect to some sites when using DIR-615
« Reply #2 on: September 06, 2010, 08:19:38 AM »

Thanks for the reply.
I tried 1400, 1410,1420,...1490 and rebooted the router each time.
No luck.
I even tried to find the otimum value for MTU by using the proc found at http://www.dslreports.com/faq/5793
It happed to be 1450 (and bellow that like 1440, etc)
I also noticed that if I keep refreshing some pages maybe 10-20 times, it sometimes loads that page (partially).
I noticed a few months ago, I couldn't access Google.com
I thought maybe some hacker is getting even with Google and crashed their network. So I used ping insted. After 2 days it came back all by itself. But my freind told me later that there was no problem with google!
Any other ideas?
Logged

IrqReq

  • Level 1 Member
  • *
  • Posts: 3
Re: Can't connect to some sites when using DIR-615
« Reply #3 on: September 06, 2010, 08:30:25 AM »

If I thought throwing this router out and buying another brand would help, I would do it. Except I had a linksys before and I had nothing but problems with that one. It kept freezing up and I had to cycle the power once every couple of weeks. Tech support was located in another planet that didn't even speak proper English.
Quality has no meaning these days. It's just a meaningless word everyone uses.
No one says "Buy my product, it's not very good, actually its pretty crappy, but hey, it's cheap and its on sale"!!
Just venting...
Logged